linux-libc-headers-2.6.29: fix DVB header files for userspace
authorAndreas Oberritter <obi@opendreambox.org>
Mon, 13 Jul 2009 22:40:08 +0000 (00:40 +0200)
committerAndreas Oberritter <obi@opendreambox.org>
Mon, 13 Jul 2009 22:40:08 +0000 (00:40 +0200)
recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb

index 6caddc0..ecfcf95 100644 (file)
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
 
 INHIBIT_DEFAULT_DEPS = "1"
 DEPENDS += "unifdef-native"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
          "
@@ -30,6 +30,15 @@ set_arch() {
        esac
 }
 
+do_unpack_append() {
+       bb.build.exec_func('do_replace_linux_types', d)
+}
+
+do_replace_linux_types() {
+       # linux/types.h conflicts with glibc headers
+       sed -i 's,^#include <linux/types.h>,#include <asm/types.h>,' ${S}/include/linux/dvb/*.h
+}
+
 do_configure() {
        set_arch
        oe_runmake allnoconfig ARCH=$ARCH