gnumeric updated to version 1.8.2:
authorStanislav Brabec <utx@penguin.cz>
Sun, 6 Apr 2008 23:41:39 +0000 (23:41 +0000)
committerStanislav Brabec <utx@penguin.cz>
Sun, 6 Apr 2008 23:41:39 +0000 (23:41 +0000)
* new stable branch

packages/gnumeric/files/remove-docs.patch
packages/gnumeric/gnumeric_1.6.3.bb [deleted file]
packages/gnumeric/gnumeric_1.8.2.bb [new file with mode: 0644]

index 4a9108b..650ad6f 100644 (file)
@@ -1,8 +1,10 @@
---- gnumeric-1.5.2/Makefile.am.orig    2005-08-01 11:32:36.119921544 +0000
-+++ gnumeric-1.5.2/Makefile.am 2005-08-01 11:32:44.689618752 +0000
+Index: gnumeric-1.8.2/Makefile.am
+===================================================================
+--- gnumeric-1.8.2.orig/Makefile.am    2008-01-15 02:53:04.000000000 +0000
++++ gnumeric-1.8.2/Makefile.am 2008-04-01 22:44:44.000000000 +0000
 @@ -1,4 +1,4 @@
--SUBDIRS = . po po-functions src plugins icons templates doc schemas
-+SUBDIRS = . po po-functions src plugins icons templates schemas
- if WITH_WIN32
-   SUBDIRS += tools
- endif
+-SUBDIRS = . po po-functions src plugins icons templates doc tools schemas test
++SUBDIRS = . po po-functions src plugins icons templates tools schemas test
+ XML_I18N_XML_KIND = --pass-through
diff --git a/packages/gnumeric/gnumeric_1.6.3.bb b/packages/gnumeric/gnumeric_1.6.3.bb
deleted file mode 100644 (file)
index 9c757fb..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-LICENSE = "GPL"
-SECTION = "x11/utils"
-S = "${WORKDIR}/gnumeric-${PV}"
-DEPENDS = "libgsf gtk+ libxml2 goffice libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libgnomeprintui libbonoboui"
-DESCRIPTION = "Gnumeric spreadsheet for GNOME"
-
-PR = "r1"
-
-inherit gnome flow-lossage
-
-SRC_URI += "file://remove-docs.patch;patch=1"
-
-EXTRA_OECONF=" --without-perl "
-
-PACKAGES_DYNAMIC = "gnumeric-plugin-*"
-
-FILES_${PN}-dbg += "${libdir}/gnumeric/1.6.3/plugins/*/.debug"
-FILES_gnumeric_append = " /usr/lib/libspreadsheet-${PV}.so "
-
-python populate_packages_prepend () {
-       gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
-
-       do_split_packages(d, gnumeric_libdir, '(.*)', 'gnumeric-plugin-%s', 'Gnumeric plugin for %s', allow_dirs=True)
-}
diff --git a/packages/gnumeric/gnumeric_1.8.2.bb b/packages/gnumeric/gnumeric_1.8.2.bb
new file mode 100644 (file)
index 0000000..f765411
--- /dev/null
@@ -0,0 +1,29 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+S = "${WORKDIR}/gnumeric-${PV}"
+DEPENDS = "libgsf gtk+ libxml2 goffice libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libgnomeprintui libbonoboui orbit2-native"
+DESCRIPTION = "Gnumeric spreadsheet for GNOME"
+
+PR = "r1"
+
+inherit gnome flow-lossage
+
+SRC_URI += "file://remove-docs.patch;patch=1"
+
+EXTRA_OECONF=" --without-perl "
+
+PACKAGES_DYNAMIC = "gnumeric-plugin-*"
+
+FILES_${PN}-dbg += "${libdir}/gnumeric/1.8.2/plugins/*/.debug"
+FILES_gnumeric_append = " /usr/lib/libspreadsheet-${PV}.so "
+
+# We need native orbit-idl with target idl files. No way to say it in a clean way:
+do_configure_append () {
+       find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
+}
+
+python populate_packages_prepend () {
+       gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
+
+       do_split_packages(d, gnumeric_libdir, '(.*)', 'gnumeric-plugin-%s', 'Gnumeric plugin for %s', allow_dirs=True)
+}