python-cython: add bugfix release 0.12.1
authorMartin Jansa <Martin.Jansa@gmail.com>
Thu, 4 Feb 2010 08:27:46 +0000 (09:27 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Thu, 4 Feb 2010 08:48:07 +0000 (09:48 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
recipes/python/python-cython-native_0.12.1.bb [new file with mode: 0644]
recipes/python/python-cython_0.12.1.bb [new file with mode: 0644]

diff --git a/recipes/python/python-cython-native_0.12.1.bb b/recipes/python/python-cython-native_0.12.1.bb
new file mode 100644 (file)
index 0000000..95886ae
--- /dev/null
@@ -0,0 +1,10 @@
+require python-cython_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+
+do_stage() {
+    PYTHONPATH=${STAGING_BINDIR} BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+    STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
+        ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
+}
diff --git a/recipes/python/python-cython_0.12.1.bb b/recipes/python/python-cython_0.12.1.bb
new file mode 100644 (file)
index 0000000..b3e9d8b
--- /dev/null
@@ -0,0 +1,16 @@
+DESCRIPTION = "Cython is a language specially designed for writing Python extension modules. \
+It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \
+and the messy, low-level world of C."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRCNAME = "Cython"
+PR = "ml0"
+
+SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz;name=archive"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[archive.md5sum] = "cf9f98e982258f8516620277975016f3"
+SRC_URI[archive.sha256sum] = "0f384ec20c579b80d1960a5795d6517a6885305efa9964bcbf6a7b8da88b9c77"
+
+inherit distutils