python-dbus 0.82.4 update to 0.83.0
authorMichael Lauer <mickey@vanille-media.de>
Fri, 1 Aug 2008 18:47:27 +0000 (18:47 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Fri, 1 Aug 2008 18:47:27 +0000 (18:47 +0000)
conf/distro/include/preferred-om-2008-versions.inc
packages/python/python-dbus_0.83.0.bb [new file with mode: 0644]

index a936259..c3e4b41 100644 (file)
@@ -1506,7 +1506,7 @@ PREFERRED_VERSION_python24-sip ?= "4.1.1"
 PREFERRED_VERSION_python ?= "2.5.2"
 PREFERRED_VERSION_python-ao ?= "0.82"
 PREFERRED_VERSION_python-constraint ?= "1.1"
-PREFERRED_VERSION_python-dbus ?= "0.82.4"
+PREFERRED_VERSION_python-dbus ?= "0.83.0"
 PREFERRED_VERSION_python-fam ?= "1.1.1"
 PREFERRED_VERSION_python-fnorb ?= "1.3"
 PREFERRED_VERSION_python-fpconst ?= "0.6.0"
diff --git a/packages/python/python-dbus_0.83.0.bb b/packages/python/python-dbus_0.83.0.bb
new file mode 100644 (file)
index 0000000..4ccecc0
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+RDEPENDS = "python-io python-logging python-stringold python-threading python-xml"
+PR = "ml0"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+export BUILD_SYS := "${BUILD_SYS}"
+export HOST_SYS := "${HOST_SYS}"
+
+do_stage() {
+       autotools_stage_all
+}
+
+FILES_${PN}-dev += "${libdir}/pkgconfig