pcmciautils: add 014
authorMarcin Juszkiewicz <hrw@openembedded.org>
Sun, 29 Oct 2006 12:54:50 +0000 (12:54 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Sun, 29 Oct 2006 12:54:50 +0000 (12:54 +0000)
packages/pcmciautils/pcmciautils-014/.mtn2git_empty [new file with mode: 0644]
packages/pcmciautils/pcmciautils-014/makefile_fix.patch [new file with mode: 0644]
packages/pcmciautils/pcmciautils-014/version_workaround.patch [new file with mode: 0644]
packages/pcmciautils/pcmciautils_014.bb [new file with mode: 0644]

diff --git a/packages/pcmciautils/pcmciautils-014/.mtn2git_empty b/packages/pcmciautils/pcmciautils-014/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/pcmciautils/pcmciautils-014/makefile_fix.patch b/packages/pcmciautils/pcmciautils-014/makefile_fix.patch
new file mode 100644 (file)
index 0000000..fed5d37
--- /dev/null
@@ -0,0 +1,15 @@
+Hardcoded paths are bad...
+
+Index: pcmciautils-014/Makefile
+===================================================================
+--- pcmciautils-014.orig/Makefile      2006-06-01 11:07:52.000000000 +0200
++++ pcmciautils-014/Makefile   2006-10-29 13:50:25.000000000 +0100
+@@ -69,7 +69,7 @@
+ mandir =      ${prefix}/usr/share/man
+ srcdir = .
+-INSTALL = /usr/bin/install -c
++INSTALL = install -c
+ INSTALL_PROGRAM = ${INSTALL}
+ INSTALL_DATA  = ${INSTALL} -m 644
+ INSTALL_SCRIPT = ${INSTALL_PROGRAM}
diff --git a/packages/pcmciautils/pcmciautils-014/version_workaround.patch b/packages/pcmciautils/pcmciautils-014/version_workaround.patch
new file mode 100644 (file)
index 0000000..962aa4e
--- /dev/null
@@ -0,0 +1,16 @@
+PCMCIAUTILS_VERSION is specified on the commandline but doesn't compile properly 
+under arm gcc 3.4.x so we work around it.
+
+Index: pcmciautils-013/src/pccardctl.c
+===================================================================
+--- pcmciautils-013.orig/src/pccardctl.c       2006-03-26 11:56:41.000000000 +0100
++++ pcmciautils-013/src/pccardctl.c    2006-05-09 22:11:09.000000000 +0100
+@@ -350,7 +350,7 @@
+ }
+ static void print_header(void) {
+-      printf("pcmciautils %s\n", PCMCIAUTILS_VERSION);
++      printf("pcmciautils 014\n");
+       printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n");
+       printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n");
+ }
diff --git a/packages/pcmciautils/pcmciautils_014.bb b/packages/pcmciautils/pcmciautils_014.bb
new file mode 100644 (file)
index 0000000..3dde683
--- /dev/null
@@ -0,0 +1,33 @@
+DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
+DEPENDS = "sysfsutils udev module-init-tools"
+RDEPENDS = "udev module-init-tools"
+HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+
+SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2 \
+           file://makefile_fix.patch;patch=1 \
+          file://version_workaround.patch;patch=1"
+S = "${WORKDIR}/pcmciautils-${PV}"
+
+PR = "r0"
+
+export HOSTCC = "${BUILD_CC}"
+export etcdir = "${sysconfdir}"
+export sbindir = "${base_sbindir}"
+export pcmciaconfdir = "${sysconfdir}/pcmcia"
+export udevrulesdir = "${sysconfdir}/udev/rules.d"
+export UDEV = 1
+LD = "${CC}"
+CFLAGS =+ "-I${S}/src"
+CFLAGS =+ '-DPCMCIAUTILS_VERSION=013'
+
+PARALLEL_MAKE = ""
+EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
+
+do_install () {
+       oe_runmake 'DESTDIR=${D}' install
+}
+
+CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts"
+RCONFLICTS_${PN} += "pcmcia-cs"