freetype: update to 2.3.4. Closes 2218.
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>
Tue, 19 Jun 2007 15:37:30 +0000 (15:37 +0000)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Tue, 19 Jun 2007 15:37:30 +0000 (15:37 +0000)
packages/freetype/freetype-2.3.3/.mtn2git_empty [deleted file]
packages/freetype/freetype-2.3.3/fix-x86_64-build.patch [deleted file]
packages/freetype/freetype-2.3.4/.mtn2git_empty [new file with mode: 0644]
packages/freetype/freetype-2.3.4/fix-x86_64-build.patch [new file with mode: 0644]
packages/freetype/freetype_2.3.3.bb [deleted file]
packages/freetype/freetype_2.3.4.bb [new file with mode: 0644]

diff --git a/packages/freetype/freetype-2.3.3/.mtn2git_empty b/packages/freetype/freetype-2.3.3/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/freetype/freetype-2.3.3/fix-x86_64-build.patch b/packages/freetype/freetype-2.3.3/fix-x86_64-build.patch
deleted file mode 100644 (file)
index ae504dc..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: freetype-2.3.1/builds/unix/configure.raw
-===================================================================
---- freetype-2.3.1.orig/builds/unix/configure.raw
-+++ freetype-2.3.1/builds/unix/configure.raw
-@@ -40,7 +40,7 @@ AC_SUBST(EXEEXT)
- # checks for native programs to generate building tool
- if test ${cross_compiling} = yes; then
--  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build-gcc})
-+  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build}-gcc)
-   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, gcc, gcc)
-   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, cc, cc, , , /usr/ucb/cc)
-   test -z "${CC_BUILD}" && AC_MSG_ERROR([cannot find native C compiler])
-Index: freetype-2.3.1/builds/unix/configure.ac
-===================================================================
---- freetype-2.3.1.orig/builds/unix/configure.ac
-+++ freetype-2.3.1/builds/unix/configure.ac
-@@ -40,7 +40,7 @@ AC_SUBST(EXEEXT)
- # checks for native programs to generate building tool
- if test ${cross_compiling} = yes; then
--  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build-gcc})
-+  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build}-gcc)
-   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, gcc, gcc)
-   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, cc, cc, , , /usr/ucb/cc)
-   test -z "${CC_BUILD}" && AC_MSG_ERROR([cannot find native C compiler])
diff --git a/packages/freetype/freetype-2.3.4/.mtn2git_empty b/packages/freetype/freetype-2.3.4/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/freetype/freetype-2.3.4/fix-x86_64-build.patch b/packages/freetype/freetype-2.3.4/fix-x86_64-build.patch
new file mode 100644 (file)
index 0000000..ae504dc
--- /dev/null
@@ -0,0 +1,26 @@
+Index: freetype-2.3.1/builds/unix/configure.raw
+===================================================================
+--- freetype-2.3.1.orig/builds/unix/configure.raw
++++ freetype-2.3.1/builds/unix/configure.raw
+@@ -40,7 +40,7 @@ AC_SUBST(EXEEXT)
+ # checks for native programs to generate building tool
+ if test ${cross_compiling} = yes; then
+-  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build-gcc})
++  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build}-gcc)
+   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, gcc, gcc)
+   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, cc, cc, , , /usr/ucb/cc)
+   test -z "${CC_BUILD}" && AC_MSG_ERROR([cannot find native C compiler])
+Index: freetype-2.3.1/builds/unix/configure.ac
+===================================================================
+--- freetype-2.3.1.orig/builds/unix/configure.ac
++++ freetype-2.3.1/builds/unix/configure.ac
+@@ -40,7 +40,7 @@ AC_SUBST(EXEEXT)
+ # checks for native programs to generate building tool
+ if test ${cross_compiling} = yes; then
+-  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build-gcc})
++  AC_CHECK_PROG(CC_BUILD, ${build}-gcc, ${build}-gcc)
+   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, gcc, gcc)
+   test -z "${CC_BUILD}" && AC_CHECK_PROG(CC_BUILD, cc, cc, , , /usr/ucb/cc)
+   test -z "${CC_BUILD}" && AC_MSG_ERROR([cannot find native C compiler])
diff --git a/packages/freetype/freetype_2.3.3.bb b/packages/freetype/freetype_2.3.3.bb
deleted file mode 100644 (file)
index c1febe8..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-DESCRIPTION = "Freetype font rendering library"
-SECTION = "libs"
-LICENSE = "freetype"
-PR = "r2"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
-           file://fix-x86_64-build.patch;patch=1 \
-           file://no-hardcode.patch;patch=1 \
-         "
-
-S = "${WORKDIR}/freetype-${PV}"
-
-inherit autotools pkgconfig binconfig
-
-DEFAULT_PREFERENCE = "-1"
-
-LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
-EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
-EXTRA_OECONF = "--without-zlib"
-
-do_configure() {
-       cd builds/unix
-       gnu-configize
-       aclocal -I .
-       autoconf
-       cd ${S}
-       oe_runconf
-}
-
-do_compile_prepend() {
-       ${BUILD_CC} -o objs/apinames src/tools/apinames.c
-}
-
-do_stage() {
-     export LIBTOOL='${LIBTOOL}'
-        autotools_stage_all
-        oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
-}
-
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}"
diff --git a/packages/freetype/freetype_2.3.4.bb b/packages/freetype/freetype_2.3.4.bb
new file mode 100644 (file)
index 0000000..c1febe8
--- /dev/null
@@ -0,0 +1,41 @@
+DESCRIPTION = "Freetype font rendering library"
+SECTION = "libs"
+LICENSE = "freetype"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+           file://fix-x86_64-build.patch;patch=1 \
+           file://no-hardcode.patch;patch=1 \
+         "
+
+S = "${WORKDIR}/freetype-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+DEFAULT_PREFERENCE = "-1"
+
+LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+EXTRA_OECONF = "--without-zlib"
+
+do_configure() {
+       cd builds/unix
+       gnu-configize
+       aclocal -I .
+       autoconf
+       cd ${S}
+       oe_runconf
+}
+
+do_compile_prepend() {
+       ${BUILD_CC} -o objs/apinames src/tools/apinames.c
+}
+
+do_stage() {
+     export LIBTOOL='${LIBTOOL}'
+        autotools_stage_all
+        oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"