python: fix libffi building for mips. Should close #5001
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Thu, 29 Jan 2009 09:09:33 +0000 (10:09 +0100)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Thu, 29 Jan 2009 09:11:47 +0000 (10:11 +0100)
packages/python/files/06-libffi-enable-default-mips.patch [new file with mode: 0644]
packages/python/python_2.6.1.bb

diff --git a/packages/python/files/06-libffi-enable-default-mips.patch b/packages/python/files/06-libffi-enable-default-mips.patch
new file mode 100644 (file)
index 0000000..b01f0c7
--- /dev/null
@@ -0,0 +1,12 @@
+Index: Python-2.6.1/Modules/_ctypes/libffi/fficonfig.py.in
+===================================================================
+--- Python-2.6.1.orig/Modules/_ctypes/libffi/fficonfig.py.in
++++ Python-2.6.1/Modules/_ctypes/libffi/fficonfig.py.in
+@@ -5,6 +5,7 @@ src/prep_cif.c
+ ffi_platforms = {
+     'MIPS_IRIX': ['src/mips/ffi.c', 'src/mips/o32.S', 'src/mips/n32.S'],
+     'MIPS_LINUX': ['src/mips/ffi.c', 'src/mips/o32.S'],
++    'MIPS': ['src/mips/ffi.c', 'src/mips/o32.S'],
+     'X86': ['src/x86/ffi.c', 'src/x86/sysv.S'],
+     'X86_FREEBSD': ['src/x86/ffi.c', 'src/x86/sysv.S'],
+     'X86_WIN32': ['src/x86/ffi.c', 'src/x86/win32.S'],
index c0eb596..8c3f354 100644 (file)
@@ -1,7 +1,7 @@
 require python.inc
 DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl tk zlib"
 DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-PR = "ml1"
+PR = "ml2"
 
 SRC_URI = "\
   http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
@@ -11,6 +11,7 @@ SRC_URI = "\
   file://03-fix-tkinter-detection.patch;patch=1 \
   file://04-default-is-optimized.patch;patch=1 \
   file://05-enable-ctypes-cross-build.patch;patch=1 \
+  file://06-libffi-enable-default-mips.patch;patch=1 \
   \
 # not yet pushed forward
 # sitecustomize, sitebranding