gob2: add gob2, a GObject support package
authorJustin Patrin <papercrane@gmail.com>
Tue, 23 Jan 2007 20:36:07 +0000 (20:36 +0000)
committerJustin Patrin <papercrane@gmail.com>
Tue, 23 Jan 2007 20:36:07 +0000 (20:36 +0000)
packages/gob2/.mtn2git_empty [new file with mode: 0644]
packages/gob2/gob2_2.0.14.bb [new file with mode: 0644]

diff --git a/packages/gob2/.mtn2git_empty b/packages/gob2/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gob2/gob2_2.0.14.bb b/packages/gob2/gob2_2.0.14.bb
new file mode 100644 (file)
index 0000000..89f64d0
--- /dev/null
@@ -0,0 +1,17 @@
+LICENSE = "LGPL"
+DESCRIPTION = "A library to make creating GObjects easier"
+HOMEPAGE = "http://www.5z.com/jirka/gob.html"
+SECTION = "libs"
+DEPENDS = "gtk+ bison flex"
+SRC_URI = "http://ftp.5z.com/pub/gob/gob2-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+    find ${S} -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
+    find ${S} -name Makefile | xargs sed -i 's~-I$(includedir)~-I${STAGING_INCDIR}~g'
+}
+
+do_stage_append() {
+    install -m 0644 ${S}/gob2.m4 ${STAGING_DATADIR}/aclocal
+}