cups: use LDFLAGS for shared libs (fixes QA error)
authorJeremy Lainé <jeremy.laine@m4x.org>
Mon, 6 Apr 2009 11:44:40 +0000 (11:44 +0000)
committerJeremy Lainé <jeremy.laine@m4x.org>
Mon, 6 Apr 2009 11:44:40 +0000 (11:44 +0000)
recipes/cups/cups.inc
recipes/cups/cups_1.2.12.bb
recipes/cups/cups_1.3.8.bb

index bbf2377..59075fb 100644 (file)
@@ -8,8 +8,6 @@ SRC_URI = "ftp://ftp.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
 
 inherit autotools binconfig
 
-LDFLAGS += " -L${STAGING_LIBDIR} "
-
 EXTRA_OECONF = " \
                 --enable-gnutls \
                --enable-dbus \
@@ -26,7 +24,7 @@ EXTRA_OECONF = " \
 do_configure() {
        gnu-configize
        libtoolize --force
-       oe_runconf
+       DSOFLAGS="${LDFLAGS}" oe_runconf
 }
 
 do_compile () {
index bbe3c5d..4f7d0d4 100644 (file)
@@ -1,2 +1,2 @@
 require cups.inc
-PR = "r1"
+PR = "r2"
index e9fd985..79cbc32 100644 (file)
@@ -1,7 +1,7 @@
 require cups.inc
 
 SRC_URI += "file://use_echo_only_in_init.patch;patch=1"
-PR = "r1"
+PR = "r2"
 
 DEFAULT_PREFERENCE = "-1"