gdal: update to 1.5.2
authorKoen Kooi <koen@openembedded.org>
Tue, 14 Oct 2008 10:37:56 +0000 (10:37 +0000)
committerKoen Kooi <koen@openembedded.org>
Tue, 14 Oct 2008 10:37:56 +0000 (10:37 +0000)
packages/gdal/gdal_1.5.2.bb [new file with mode: 0644]

diff --git a/packages/gdal/gdal_1.5.2.bb b/packages/gdal/gdal_1.5.2.bb
new file mode 100644 (file)
index 0000000..60162e1
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE = "http://www.gdal.org/"
+LICENSE = "MIT"
+DEPENDS = "proj-4 sqlite3 zlib jpeg libpng jasper expat"
+
+SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--without-perl \
+                --without-python \
+                --without-php \
+                --without-ruby \
+                --with-libz=${STAGING_DIR_TARGET} \
+                --with-png=${STAGING_DIR_TARGET} \
+                --with-jpeg=${STAGING_DIR_TARGET} \
+                --with-jasper=${STAGING_DIR_TARGET} \
+                --with-libtiff=${STAGING_DIR_TARGET} \
+                --with-expat=${STAGING_DIR_TARGET} \
+                --with-expat-inc=${STAGING_INCDIR} \
+                --with-expat-lib=${STAGING_LIBDIR} \
+"
+
+# GDAL clutter /usr/share with files instead of using a subdir :(
+FILES_${PN} += "${datadir}"
+
+do_stage() {
+        autotools_stage_all
+}      
+