Fix the bash build for uclibc and kill the dangerous /bin/sh alternatives bits.
authorChris Larson <clarson@kergoth.com>
Wed, 9 Mar 2005 11:39:50 +0000 (11:39 +0000)
committerChris Larson <clarson@kergoth.com>
Wed, 9 Mar 2005 11:39:50 +0000 (11:39 +0000)
BKrev: 422ee086sm4RBQy79-EAyaUdInS9NA

packages/bash/bash_3.0.bb

index b7b40cf..9248988 100644 (file)
@@ -3,8 +3,7 @@ HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
 DEPENDS = "ncurses"
 SECTION = "base/shell"
 LICENSE = "GPL"
-PROVIDES = "virtual/sh"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
        file://signames-mipsel.diff;patch=1"
@@ -18,22 +17,6 @@ EXTRA_OECONF = "--with-ncurses"
 export CC_FOR_BUILD = "${BUILD_CC}"
 
 do_configure () {
+       gnu-configize
        oe_runconf
 }
-
-# dont use update-alternatives class because since we are dealing with /bin/sh
-# we need to do the remove in pkg_prerm where the /bin/sh link still points
-# to something (postrm is a shell script)
-
-ALTERNATIVE_NAME = "sh"
-ALTERNATIVE_PATH = "${bindir}/bash"
-ALTERNATIVE_PRIORITY = "30"
-ALTERNATIVE_LINK = "${bindir}/${ALTERNATIVE_NAME}"
-
-pkg_postinst() {
-update-alternatives --install ${ALTERNATIVE_LINK} ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH} ${ALTERNATIVE_PRIORITY}
-}
-
-pkg_prerm() {
-update-alternatives --remove ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH}
-}