iqnotes: added 2.1.0-rc1 version
authorMarcin Juszkiewicz <hrw@openembedded.org>
Fri, 30 Dec 2005 14:23:16 +0000 (14:23 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Fri, 30 Dec 2005 14:23:16 +0000 (14:23 +0000)
- I do not know how to get it working without patching .pro file ;(

packages/iqnotes/files/.mtn2git_empty [new file with mode: 0644]
packages/iqnotes/files/pro.patch [new file with mode: 0644]
packages/iqnotes/iqnotes_2.0.99-2.1.0rc1.bb [new file with mode: 0644]

diff --git a/packages/iqnotes/files/.mtn2git_empty b/packages/iqnotes/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/iqnotes/files/pro.patch b/packages/iqnotes/files/pro.patch
new file mode 100644 (file)
index 0000000..b2e5d88
--- /dev/null
@@ -0,0 +1,10 @@
+--- iqnotes/iqnotes.pro.orig   2005-12-30 13:38:24.000000000 +0100
++++ iqnotes/iqnotes.pro        2005-12-30 13:39:01.000000000 +0100
+@@ -1,6 +1,5 @@
+ TEMPLATE = app
+-#CONFIG = qt warn_on pda
+-CONFIG = qt warn_on debug desktop
++CONFIG = qt warn_on pda
+ DEFINES = TOOLBAR_BIG_ICONS
+ pda:INCLUDEPATH += $(QPEDIR)/include
+ DESTDIR = ../bin
diff --git a/packages/iqnotes/iqnotes_2.0.99-2.1.0rc1.bb b/packages/iqnotes/iqnotes_2.0.99-2.1.0rc1.bb
new file mode 100644 (file)
index 0000000..b205c33
--- /dev/null
@@ -0,0 +1,36 @@
+DESCRIPTION = "IQNotes is notes kept in a hierarchical(tree like) manner. \
+It handles todo, events, sketching. It can acts as a contact, password, \
+credit card manager and even more, because is highly configurable. \
+Data can be crypted by strong AES algorithm."
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "virtual/libqpe"
+HOMEPAGE = "http://iqnotes.berlios.de"
+AUTHOR = "Peter Vrabel <kybu@users.berlios.de>"
+
+#upstream version
+UPV = "2.1.0rc1"
+
+SRC_URI = "http://download.berlios.de/iqnotes/iqnotes-${UPV}.tar.bz2 \
+           file://pro.patch;patch=1"
+
+S = "${WORKDIR}/iqnotes-${UPV}/iqnotes/"
+
+EXTRA_QMAKEVARS_POST += "CONFIG-=desktop CONFIG-=debug CONFIG+=pda LIBS-=-lqtopia"
+inherit palmtop
+
+export OE_QMAKE_LINK="${CXX}"
+
+do_install() {
+        install -d ${D}${palmtopdir}/help/html \
+                  ${D}${palmtopdir}/bin \
+                  ${D}${palmtopdir}/apps/Applications \
+                  ${D}${palmtopdir}/pics/iqnotes/items \
+                  ${D}${palmtopdir}/iqnotes/icons
+        install -m 0755 ${S}/../bin/iqnotes ${D}${palmtopdir}/bin/
+        install -m 0644 ${S}/../apps/Applications/*.desktop ${D}${palmtopdir}/apps/Applications/
+        install -m 0644 ${S}/../pics/iqnotes/*.png ${D}${palmtopdir}/pics/iqnotes/
+        install -m 0644 ${S}/../help/html/iqnotes.html ${D}${palmtopdir}/help/html/
+        install -m 0644 ${S}/../pics/*.xpm ${D}${palmtopdir}/pics/
+}