reverted koen's change get this compile again on systems that do
authorHolger Schurig <schurig@mn-solutions.de>
Wed, 27 Apr 2005 11:47:01 +0000 (11:47 +0000)
committerHolger Schurig <schurig@mn-solutions.de>
Wed, 27 Apr 2005 11:47:01 +0000 (11:47 +0000)
BBMASK or equivalent for speedier build and that don't have X11-libs
in their staging because of this.

After all, neither the libvncserver.a file nor the java classes need
X11 for them.

Added a new x11vnc.bb file that koen or XorA will review.

BKrev: 426f7bb5oDlmXGutwfu2r1i0a9v-JQ

packages/libvncserver/libvncserver_0.7.1.bb

index 6129fff..1ae86ea 100644 (file)
@@ -1,20 +1,19 @@
 DESCRIPTION = "library for easy implementation of a RDP/VNC server"
 SECTION = "libs"
 PRIORITY = "optional"
-DEPENDS = "zlib jpeg x11"
+DEPENDS = "zlib jpeg"
 LICENSE = "GPL"
-PACKAGES = "x11vnc libvncserver-storepasswd libvncserver-javaapplet"
+PACKAGES = "libvncserver-storepasswd libvncserver-javaapplet"
 FILES_libvncserver-storepasswd = "${bindir}/storepasswd"
 FILES_libvncserver-javaapplet = "/${datadir}fbvncserver/classes/index.vnc \
                                 /${datadir}fbvncserver/classes/VncViewer.jar"
-FILES_x11vnc = "${bindir}/x11vnc"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/LibVNCServer-${PV}.tar.gz"
 
 CFLAGS_append = " -D_REENTRANT"
 S = "${WORKDIR}/LibVNCServer-${PV}"
-# Original SUBDIRS is='libvncserver examples contrib vncterm classes libvncclient client_examples test'
-EXTRA_OEMAKE_append=" SUBDIRS='libvncserver x11vnc examples classes'"
+# Original SUBDIRS is='libvncserver examples contrib x11vnc vncterm classes libvncclient client_examples test'
+EXTRA_OEMAKE_append=" SUBDIRS='libvncserver examples classes'"
 
 inherit autotools
 
@@ -30,7 +29,6 @@ do_stage () {
 do_install () {
        install -d ${D}${bindir}
        install -m 0755 examples/storepasswd ${D}${bindir}
-       install -m 0755 x11vnc/x11vnc ${D}${bindir}
        install -d ${D}${datadir}fbvncserver/classes
        install -m 0644 classes/index.vnc ${D}${datadir}fbvncserver/classes/
        install -m 0644 classes/VncViewer.jar ${D}${datadir}fbvncserver/classes/