gpe-announce 0.13: Fix for libsoundgen 0.5.
authorSergey Lapin <slapinid@gmail.com>
Thu, 14 Jun 2007 22:56:44 +0000 (22:56 +0000)
committerPaul Sokolovsky <pmiscml@gmail.com>
Thu, 14 Jun 2007 22:56:44 +0000 (22:56 +0000)
packages/gpe-announce/files/.mtn2git_empty [new file with mode: 0644]
packages/gpe-announce/files/fix-esound.diff [new file with mode: 0644]
packages/gpe-announce/gpe-announce_0.13.bb

diff --git a/packages/gpe-announce/files/.mtn2git_empty b/packages/gpe-announce/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gpe-announce/files/fix-esound.diff b/packages/gpe-announce/files/fix-esound.diff
new file mode 100644 (file)
index 0000000..71ff7e8
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN gpe-announce-0.13/callbacks.c gpe-announce-0.13-new/callbacks.c
+--- gpe-announce-0.13/callbacks.c      2007-06-14 20:56:15.000000000 +0400
++++ gpe-announce-0.13-new/callbacks.c  2005-08-24 23:04:31.000000000 +0400
+@@ -28,7 +28,7 @@
+ #include <linux/soundcard.h>
+ #include <pthread.h>
+-#include <gpe/soundgen.h>
++#include <soundgen.h>
+ #include <gpe/schedule.h>
+ #include <linux/types.h>
+diff -ruN gpe-announce-0.13/Makefile gpe-announce-0.13-new/Makefile
+--- gpe-announce-0.13/Makefile 2007-06-14 20:30:00.000000000 +0400
++++ gpe-announce-0.13-new/Makefile     2007-06-14 20:28:30.000000000 +0400
+@@ -43,7 +43,7 @@
+ all: $(PACKAGE)
+ $(PACKAGE): $(OBJS)
+-      $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS) -lsoundgen -lschedule
++      $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS) -lsoundgen -lschedule -lesd
+ install-program: all 
+       install -d $(DESTDIR)$(PREFIX)/bin
index 6124b4c..6ffe317 100644 (file)
@@ -2,4 +2,6 @@ inherit gpe
 
 DEPENDS = "libsoundgen libschedule gtk+ libgpewidget"
 LICENSE = "GPL"
+PR = "r1"
 
+SRC_URI += "file://fix-esound.diff;patch=1"