alsa-state: add config for a780
authorKoen Kooi <koen@openembedded.org>
Fri, 21 Sep 2007 10:10:32 +0000 (10:10 +0000)
committerKoen Kooi <koen@openembedded.org>
Fri, 21 Sep 2007 10:10:32 +0000 (10:10 +0000)
packages/alsa/alsa-state.bb
packages/alsa/alsa-state/a780/.mtn2git_empty [new file with mode: 0644]
packages/alsa/alsa-state/a780/asound.state [new file with mode: 0644]

index e2a92dc..0544dd4 100644 (file)
@@ -8,7 +8,7 @@ DESCRIPTION = "Default ALSA configuration"
 LICENSE = "GPL"
 RRECOMMENDS_alsa-state = "alsa-states"
 PV = "0.1.0"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = " \
   file://asoundrc \
diff --git a/packages/alsa/alsa-state/a780/.mtn2git_empty b/packages/alsa/alsa-state/a780/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/alsa/alsa-state/a780/asound.state b/packages/alsa/alsa-state/a780/asound.state
new file mode 100644 (file)
index 0000000..eafd409
--- /dev/null
@@ -0,0 +1,80 @@
+state.EZX {
+       control.1 {
+               comment.access 'read write'
+               comment.type INTEGER
+               comment.count 1
+               comment.range '0 - 15'
+               iface MIXER
+               name 'Output gain'
+               value 9
+       }
+       control.2 {
+               comment.access 'read write'
+               comment.type INTEGER
+               comment.count 1
+               comment.range '0 - 31'
+               iface MIXER
+               name 'Input gain'
+               value 14
+       }
+       control.3 {
+               comment.access 'read write'
+               comment.type BOOLEAN
+               comment.count 1
+               iface MIXER
+               name 'Input Mixer A3 Switch'
+               value true
+       }
+       control.4 {
+               comment.access 'read write'
+               comment.type BOOLEAN
+               comment.count 1
+               iface MIXER
+               name 'Input Mixer A5 Switch'
+               value true
+       }
+       control.5 {
+               comment.access 'read write'
+               comment.type BOOLEAN
+               comment.count 1
+               iface MIXER
+               name 'Output Mixer A1 Switch'
+               value true
+       }
+       control.6 {
+               comment.access 'read write'
+               comment.type BOOLEAN
+               comment.count 1
+               iface MIXER
+               name 'Output Mixer A2 Switch'
+               value true
+       }
+       control.7 {
+               comment.access 'read write'
+               comment.type BOOLEAN
+               comment.count 1
+               iface MIXER
+               name 'Output Mixer AR Switch'
+               value true
+       }
+       control.8 {
+               comment.access 'read write'
+               comment.type BOOLEAN
+               comment.count 1
+               iface MIXER
+               name 'Output Mixer AL Switch'
+               value true
+       }
+       control.9 {
+               comment.access 'read write'
+               comment.type ENUMERATED
+               comment.count 1
+               comment.item.0 '2ch'
+               comment.item.1 '2->1ch'
+               comment.item.2 '2->1ch -3db'
+               comment.item.3 '2->1ch -6db'
+               iface MIXER
+               name Downmixer
+               value '2ch'
+       }
+}