squashfs-tools: Added release 4.0 (for SquashFS 4.0 in Linux 2.6.29).
authorLeon Woestenberg <leon@sidebranch.com>
Sun, 19 Apr 2009 00:24:54 +0000 (02:24 +0200)
committerLeon Woestenberg <leon@sidebranch.com>
Sun, 19 Apr 2009 00:24:54 +0000 (02:24 +0200)
Added with DEFAULT_PREFERENCE -1. Be aware that squashfs release
4.0 is now upstream in Linux 2.6.29. The filesystem layout has
changed from the 3.x releases.

Distro's need to carefully select the (cross and native) version
depending on the kernel release, which again might be different for
the machines supported.

Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
conf/checksums.ini
recipes/squashfs-tools/squashfs-tools-4.0/Makefile.patch [new file with mode: 0644]
recipes/squashfs-tools/squashfs-tools-native_4.0.bb [new file with mode: 0644]
recipes/squashfs-tools/squashfs-tools_4.0.bb [new file with mode: 0644]

index 679a60b..436a031 100644 (file)
@@ -21582,6 +21582,10 @@ sha256=8423027a1e7dc238d27ec227f47ce22d1317b4c9a0a9ee49a38b6e6f8da8a5c8
 md5=95c40fca0d886893631b5de14a0af25b
 sha256=8423027a1e7dc238d27ec227f47ce22d1317b4c9a0a9ee49a38b6e6f8da8a5c8
 
+[http://downloads.sourceforge.net/squashfs/squashfs4.0.tar.gz]
+md5=a3c23391da4ebab0ac4a75021ddabf96
+sha256=18948edbe06bac2c4307eea99bfb962643e4b82e5b7edd541b4d743748e12e21
+
 [http://www.squid-cache.org/Versions/v2/2.6/squid-2.6.STABLE14.tar.bz2]
 md5=eadb138d48320df8b99349121159c6bf
 sha256=dcb0c10965430862721b675e2f9f6a30819880e03124b5e9403bfce2c7f3b69a
diff --git a/recipes/squashfs-tools/squashfs-tools-4.0/Makefile.patch b/recipes/squashfs-tools/squashfs-tools-4.0/Makefile.patch
new file mode 100644 (file)
index 0000000..2c88aba
--- /dev/null
@@ -0,0 +1,60 @@
+Index: squashfs-tools/Makefile
+===================================================================
+--- squashfs-tools.orig/Makefile       2009-04-19 01:47:43.000000000 +0200
++++ squashfs-tools/Makefile    2009-04-19 01:52:36.000000000 +0200
+@@ -1,36 +1,48 @@
+ INSTALL_DIR = /usr/local/bin
+ INCLUDEDIR = .
++CFLAGS_R = -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
++LIBS = -lz -lpthread
+ CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -O2
+ all: mksquashfs unsquashfs
+ mksquashfs: mksquashfs.o read_fs.o sort.o swap.o pseudo.o
+-      $(CC) mksquashfs.o read_fs.o sort.o swap.o pseudo.o -lz -lpthread -lm -o $@
++      $(CC) $(LDFLAGS) mksquashfs.o read_fs.o sort.o swap.o pseudo.o -lz -lpthread -lm -o $@
+ mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h squashfs_swap.h Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+ read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h squashfs_swap.h Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+ sort.o: sort.c squashfs_fs.h global.h sort.h Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+ swap.o: swap.c Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+ pseudo.o: pseudo.c pseudo.h Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+ unsquashfs: unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o unsquash-4.o swap.o
+-      $(CC) unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o unsquash-4.o swap.o -lz -lpthread -lm -o $@
++      $(CC) $(LDFLAGS) unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o unsquash-4.o swap.o -lz -lpthread -lm -o $@
+-unsquashfs.o: unsquashfs.h unsquashfs.c squashfs_fs.h squashfs_swap.h squashfs_compat.h global.h Makefile
++unsquashfs.o: unsquashfs.c unsquashfs.h squashfs_fs.h squashfs_swap.h squashfs_compat.h global.h Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+-unsquash-1.o: unsquashfs.h unsquash-1.c squashfs_fs.h squashfs_compat.h global.h Makefile
++unsquash-1.o: unsquash-1.c unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+-unsquash-2.o: unsquashfs.h unsquash-2.c unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
++unsquash-2.o: unsquash-2.c unsquashfs.h unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+-unsquash-3.o: unsquashfs.h unsquash-3.c squashfs_fs.h squashfs_compat.h global.h Makefile
++unsquash-3.o: unsquash-3.c unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+-unsquash-4.o: unsquashfs.h unsquash-4.c squashfs_fs.h squashfs_swap.h global.h Makefile
++unsquash-4.o: unsquash-4.c unsquashfs.h squashfs_fs.h squashfs_swap.h global.h Makefile
++      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+ clean:
+       -rm -f *.o mksquashfs unsquashfs
diff --git a/recipes/squashfs-tools/squashfs-tools-native_4.0.bb b/recipes/squashfs-tools/squashfs-tools-native_4.0.bb
new file mode 100644 (file)
index 0000000..87ba761
--- /dev/null
@@ -0,0 +1,11 @@
+require squashfs-tools_${PV}.bb
+PR = "r0"
+
+inherit native
+
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/squashfs-tools-${PV}', '${FILE_DIRNAME}/squashfs-tools', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+PACKAGES = ""
+
+do_stage () {
+       install -m 0755 mksquashfs ${STAGING_BINDIR}/
+}
diff --git a/recipes/squashfs-tools/squashfs-tools_4.0.bb b/recipes/squashfs-tools/squashfs-tools_4.0.bb
new file mode 100644 (file)
index 0000000..8299cd6
--- /dev/null
@@ -0,0 +1,12 @@
+require squashfs-tools.inc
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+# some release have .tgz, some have .tar.gz, so keep that outside the .inc file
+
+#http://ovh.dl.sourceforge.net/sourceforge/squashfs/squashfs4.0.tar.gz
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz \
+file://Makefile.patch;patch=1"
+