gammu: Do not execute do_stage_append creating traces of build dir.
authorStanislav Brabec <utx@penguin.cz>
Tue, 9 Sep 2008 14:17:34 +0000 (14:17 +0000)
committerStanislav Brabec <utx@penguin.cz>
Tue, 9 Sep 2008 14:17:34 +0000 (14:17 +0000)
packages/gammu/gammu_1.20.0.bb

index 617648c..6cc8644 100644 (file)
@@ -18,6 +18,13 @@ do_stage() {
     autotools_stage_all
 }
 
+# gammu has a non-standard uninstalled .pc file, which confuses pkgconfig.bbclass.
+# Replace it by custom do_stage_append():
+do_stage_append () {
+       install -d ${PKG_CONFIG_DIR}
+       cat build-configure/cfg/gammu.pc > ${PKG_CONFIG_DIR}/gammu.pc
+}
+
 PACKAGES =+ "libgammu"
 
 FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker"