recipes/linux-libc-headers: some fixes for 2.6.18 libc-headers
authorghost <andreas.monzner@multimedia-labs.de>
Sat, 6 Feb 2010 10:15:06 +0000 (11:15 +0100)
committerghost <andreas.monzner@multimedia-labs.de>
Thu, 11 Feb 2010 10:53:44 +0000 (11:53 +0100)
recipes/linux-libc-headers/linux-libc-headers-2.6.18/fix-dvb-headers.patch [new file with mode: 0644]
recipes/linux-libc-headers/linux-libc-headers-2.6.18/mips-add-missing-headers.patch [new file with mode: 0644]
recipes/linux-libc-headers/linux-libc-headers-2.6.18/mips-fix-ptrace-header.patch [new file with mode: 0644]
recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb

diff --git a/recipes/linux-libc-headers/linux-libc-headers-2.6.18/fix-dvb-headers.patch b/recipes/linux-libc-headers/linux-libc-headers-2.6.18/fix-dvb-headers.patch
new file mode 100644 (file)
index 0000000..6f3fd18
--- /dev/null
@@ -0,0 +1,20 @@
+--- linux-2.6.18/include/linux/dvb/audio.h     2007-03-10 13:05:57.000000000 +0100
++++ linux-2.6.18-fixed/include/linux/dvb/audio.h       2010-01-20 22:48:13.000000000 +0100
+@@ -27,6 +27,7 @@
+ #ifdef __KERNEL__
+ #include <linux/types.h>
+ #else
++#include <asm/types.h>
+ #include <stdint.h>
+ #endif
+--- linux-2.6.18/include/linux/dvb/video.h     2007-03-10 13:05:57.000000000 +0100
++++ linux-2.6.18-fixed/include/linux/dvb/video.h       2010-01-20 22:48:02.000000000 +0100
+@@ -29,6 +29,7 @@
+ #ifdef __KERNEL__
+ #include <linux/types.h>
+ #else
++#include <asm/types.h>
+ #include <stdint.h>
+ #include <time.h>
+ #endif
diff --git a/recipes/linux-libc-headers/linux-libc-headers-2.6.18/mips-add-missing-headers.patch b/recipes/linux-libc-headers/linux-libc-headers-2.6.18/mips-add-missing-headers.patch
new file mode 100644 (file)
index 0000000..c7d80c0
--- /dev/null
@@ -0,0 +1,6 @@
+--- linux-2.6.18/include/asm-mips/Kbuild       2010-01-18 22:57:15.000000000 +0100
++++ linux-2.6.18-brcm/include/asm-mips/Kbuild  2010-01-18 22:59:08.000000000 +0100
+@@ -1 +1,3 @@
+ include include/asm-generic/Kbuild.asm
++
++header-y += cachectl.h sgidefs.h sysmips.h
diff --git a/recipes/linux-libc-headers/linux-libc-headers-2.6.18/mips-fix-ptrace-header.patch b/recipes/linux-libc-headers/linux-libc-headers-2.6.18/mips-fix-ptrace-header.patch
new file mode 100644 (file)
index 0000000..4cbc7dc
--- /dev/null
@@ -0,0 +1,19 @@
+--- linux-2.6.18/include/asm-mips/ptrace.h     2010-01-18 22:57:15.000000000 +0100
++++ linux-2.6.18-brcm/include/asm-mips/ptrace.h        2010-01-18 22:59:08.000000000 +0100
+@@ -10,8 +10,6 @@
+ #define _ASM_PTRACE_H
+-#include <asm/isadep.h>
+-
+ /* 0 - 31 are integer registers, 32 - 63 are fp registers.  */
+ #define FPR_BASE      32
+ #define PC            64
+@@ -73,6 +71,7 @@
+ #ifdef __KERNEL__
+ #include <linux/linkage.h>
++#include <asm/isadep.h>
+ /*
+  * Does the process account for user or for system time?
index 60d621b..5871d22 100644 (file)
@@ -5,7 +5,11 @@ DEPENDS += "unifdef-native"
 PR = "r3"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
-           file://arm-syscall-define.patch;patch=1"
+           file://arm-syscall-define.patch;patch=1 \
+           file://fix-dvb-headers.patch;patch=1"
+
+SRC_URI_append_mipsel = " file://mips-add-missing-headers.patch;patch=1 \
+           file://mips-fix-ptrace-header.patch;patch=1"
 
 S = "${WORKDIR}/linux-2.6.18"
 
@@ -56,10 +60,10 @@ do_stage () {
                cp include/asm-arm/procinfo.h ${STAGE_TEMP}${includedir}/asm
        fi
        install -d ${STAGING_INCDIR}
-       rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
-       cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
-       cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
-       cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
+       for x in linux asm asm-generic linux mtd rdma scsi sound video; do
+               rm -rf ${STAGING_INCDIR}/$x;
+               cp -pfLR ${STAGE_TEMP}${includedir}/$x ${STAGING_INCDIR}/;
+       done
        # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to 
        # utsrelease.h in order to avoid recompiling a kernel every time a localversion
        # changed. Since the our headers are static and we're not compiling an