ftpd-topfield: Updated to 0.7.5 and added the syslog patch
authorRod Whitby <rod@whitby.id.au>
Fri, 28 Mar 2008 03:55:03 +0000 (03:55 +0000)
committerRod Whitby <rod@whitby.id.au>
Fri, 28 Mar 2008 03:55:03 +0000 (03:55 +0000)
packages/ftpd-topfield/files/syslog.patch [new file with mode: 0644]
packages/ftpd-topfield/ftpd-topfield_0.7.4.bb [deleted file]
packages/ftpd-topfield/ftpd-topfield_0.7.5.bb [new file with mode: 0755]

diff --git a/packages/ftpd-topfield/files/syslog.patch b/packages/ftpd-topfield/files/syslog.patch
new file mode 100644 (file)
index 0000000..8c2bf29
--- /dev/null
@@ -0,0 +1,26 @@
+--- ftpd-topfield/ftpd.c~      2008-02-16 09:49:30.000000000 +1030
++++ ftpd-topfield/ftpd.c       2008-03-24 21:45:15.000000000 +1030
+@@ -1190,6 +1190,7 @@
+               if (debug) {
+                       fprintf(stderr, "Transfer failed %lld bytes %s\n", (long long)current, srcpath);
+               }
++              syslog(LOG_INFO, "retrieve: Failed transfer of %s @%Ld", srcpath, (long long)current);
+               perror_reply (550, name);
+       }
+@@ -1363,6 +1364,7 @@
+ #endif
+       if (ret != 0) {
++              syslog(LOG_INFO, "store: Failed transfer of %s @%Ld", destpath, (long long)current);
+               perror_reply (553, name);
+               LOGCMD (*mode == 'w' ? "put" : "append", name);
+@@ -1451,6 +1453,7 @@
+                               }
+                       }
++                      syslog(LOG_INFO, "store: Failed transfer of %s @%Ld", destpath, (long long)current);
+                       /* Failed to cancel the put, so give up */
+                       perror_reply (426, "Data Connection");
+               }
diff --git a/packages/ftpd-topfield/ftpd-topfield_0.7.4.bb b/packages/ftpd-topfield/ftpd-topfield_0.7.4.bb
deleted file mode 100755 (executable)
index 356a601..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# This package builds the ftpd-topfield program
-DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
-HOMEPAGE = "http://sourceforge.net/projects/puppy"
-SECTION = "net"
-LICENSE = "MIT"
-
-SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_7_4 \
-          cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_7_4 \
-          file://init"
-
-# The source will end up in the subdirectory 'ftpd-topfield' - no release name
-S = "${WORKDIR}/ftpd-topfield"
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "ftpd-topfield"
-INITSCRIPT_PARAMS = "defaults"
-
-# Just the one package at present
-
-inherit autotools
-
-do_compile() {
-       oe_runmake
-}
-
-do_install() {
-       install -d ${D}${sbindir}
-       install -m 0755 ${S}/ftpd ${D}${sbindir}/ftpd-topfield
-        install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
-        install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ftpd-topfield
-}
diff --git a/packages/ftpd-topfield/ftpd-topfield_0.7.5.bb b/packages/ftpd-topfield/ftpd-topfield_0.7.5.bb
new file mode 100755 (executable)
index 0000000..74a3743
--- /dev/null
@@ -0,0 +1,34 @@
+# This package builds the ftpd-topfield program
+DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
+HOMEPAGE = "http://sourceforge.net/projects/puppy"
+SECTION = "net"
+LICENSE = "MIT"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_7_5 \
+          cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_7_5 \
+          file://syslog.patch;patch=1 \
+          file://init"
+
+# The source will end up in the subdirectory 'ftpd-topfield' - no release name
+S = "${WORKDIR}/ftpd-topfield"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "ftpd-topfield"
+INITSCRIPT_PARAMS = "defaults"
+
+# Just the one package at present
+
+inherit autotools
+
+do_compile() {
+       oe_runmake
+}
+
+do_install() {
+       install -d ${D}${sbindir}
+       install -m 0755 ${S}/ftpd ${D}${sbindir}/ftpd-topfield
+        install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
+        install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ftpd-topfield
+}