uclibc-0.9.30: Update ldso_hash.patch so we do not ignore LDFLAGS_GNUHASH assignment
authorKhem Raj <raj.khem@gmail.com>
Fri, 19 Dec 2008 00:49:09 +0000 (16:49 -0800)
committerKhem Raj <raj.khem@gmail.com>
Fri, 19 Dec 2008 00:49:09 +0000 (16:49 -0800)
uclibc-nptl: Ditto
uclibc-svn: Ditto

packages/uclibc/uclibc-0.9.30/ldso_hash.patch
packages/uclibc/uclibc-nptl/ldso_hash.patch
packages/uclibc/uclibc-svn/ldso_hash.patch
packages/uclibc/uclibc_0.9.30.bb

index 8a625f2..974f564 100644 (file)
@@ -1,19 +1,14 @@
-Index: uClibc-0.9.30/Rules.mak
+Index: uClibc-nptl/Rules.mak
 ===================================================================
---- uClibc-0.9.30.orig/Rules.mak       2008-11-15 16:35:00.713664783 +0100
-+++ uClibc-0.9.30/Rules.mak    2008-11-15 16:36:32.776988120 +0100
-@@ -519,13 +519,7 @@
- endif
+--- uClibc-nptl/Rules.mak      (revision 24450)
++++ uClibc-nptl/Rules.mak      (working copy)
+@@ -522,7 +522,8 @@
  
  ifeq ($(LDSO_GNU_HASH_SUPPORT),y)
--# Be sure that binutils support it
+ # Be sure that binutils support it
 -LDFLAGS_GNUHASH:=$(call check_ld,--hash-style=gnu)
--ifeq ($(LDFLAGS_GNUHASH),)
--$(error Your binutils don't support --hash-style option, while you want to use it)
--else
--LDFLAGS_NOSTRIP += -Wl,$(LDFLAGS_GNUHASH)
--endif
-+LDFLAGS_NOSTRIP += -Wl,--hash-style=gnu
- endif
- LDFLAGS:=$(LDFLAGS_NOSTRIP) -Wl,-z,defs
++#LDFLAGS_GNUHASH:=$(call check_ld,--hash-style=gnu)
++LDFLAGS_GNUHASH:=--hash-style=gnu
+ ifeq ($(LDFLAGS_GNUHASH),)
+ $(error Your binutils don't support --hash-style option, while you want to use it)
+ else
index 8a625f2..974f564 100644 (file)
@@ -1,19 +1,14 @@
-Index: uClibc-0.9.30/Rules.mak
+Index: uClibc-nptl/Rules.mak
 ===================================================================
---- uClibc-0.9.30.orig/Rules.mak       2008-11-15 16:35:00.713664783 +0100
-+++ uClibc-0.9.30/Rules.mak    2008-11-15 16:36:32.776988120 +0100
-@@ -519,13 +519,7 @@
- endif
+--- uClibc-nptl/Rules.mak      (revision 24450)
++++ uClibc-nptl/Rules.mak      (working copy)
+@@ -522,7 +522,8 @@
  
  ifeq ($(LDSO_GNU_HASH_SUPPORT),y)
--# Be sure that binutils support it
+ # Be sure that binutils support it
 -LDFLAGS_GNUHASH:=$(call check_ld,--hash-style=gnu)
--ifeq ($(LDFLAGS_GNUHASH),)
--$(error Your binutils don't support --hash-style option, while you want to use it)
--else
--LDFLAGS_NOSTRIP += -Wl,$(LDFLAGS_GNUHASH)
--endif
-+LDFLAGS_NOSTRIP += -Wl,--hash-style=gnu
- endif
- LDFLAGS:=$(LDFLAGS_NOSTRIP) -Wl,-z,defs
++#LDFLAGS_GNUHASH:=$(call check_ld,--hash-style=gnu)
++LDFLAGS_GNUHASH:=--hash-style=gnu
+ ifeq ($(LDFLAGS_GNUHASH),)
+ $(error Your binutils don't support --hash-style option, while you want to use it)
+ else
index 8a625f2..974f564 100644 (file)
@@ -1,19 +1,14 @@
-Index: uClibc-0.9.30/Rules.mak
+Index: uClibc-nptl/Rules.mak
 ===================================================================
---- uClibc-0.9.30.orig/Rules.mak       2008-11-15 16:35:00.713664783 +0100
-+++ uClibc-0.9.30/Rules.mak    2008-11-15 16:36:32.776988120 +0100
-@@ -519,13 +519,7 @@
- endif
+--- uClibc-nptl/Rules.mak      (revision 24450)
++++ uClibc-nptl/Rules.mak      (working copy)
+@@ -522,7 +522,8 @@
  
  ifeq ($(LDSO_GNU_HASH_SUPPORT),y)
--# Be sure that binutils support it
+ # Be sure that binutils support it
 -LDFLAGS_GNUHASH:=$(call check_ld,--hash-style=gnu)
--ifeq ($(LDFLAGS_GNUHASH),)
--$(error Your binutils don't support --hash-style option, while you want to use it)
--else
--LDFLAGS_NOSTRIP += -Wl,$(LDFLAGS_GNUHASH)
--endif
-+LDFLAGS_NOSTRIP += -Wl,--hash-style=gnu
- endif
- LDFLAGS:=$(LDFLAGS_NOSTRIP) -Wl,-z,defs
++#LDFLAGS_GNUHASH:=$(call check_ld,--hash-style=gnu)
++LDFLAGS_GNUHASH:=--hash-style=gnu
+ ifeq ($(LDFLAGS_GNUHASH),)
+ $(error Your binutils don't support --hash-style option, while you want to use it)
+ else
index e3155f3..16e18fb 100644 (file)
@@ -7,7 +7,7 @@
 # on whether the base patches apply to the selected (SRCDATE) svn release.
 #
 UCLIBC_BASE ?= "0.9.30"
-PR = "r2"
+PR = "r3"
 DEFAULT_PREFERENCE = "1"
 
 require uclibc.inc