gnutls: Cleanup and fixes.
authorRobert Schuster <thebohemian@gmx.net>
Thu, 17 Jan 2008 17:09:07 +0000 (17:09 +0000)
committerRobert Schuster <thebohemian@gmx.net>
Thu, 17 Jan 2008 17:09:07 +0000 (17:09 +0000)
  - move 1.6.3-specific patches into respective recipe
  - renamed patch folder to contain version to which they belong

packages/gnutls/gnutls-1.6.3/.mtn2git_empty [new file with mode: 0644]
packages/gnutls/gnutls-1.6.3/configure_madness.patch [new file with mode: 0644]
packages/gnutls/gnutls-1.6.3/gnutls-openssl.patch [new file with mode: 0644]
packages/gnutls/gnutls-1.6.3/gnutls-texinfo-euro.patch [new file with mode: 0644]
packages/gnutls/gnutls.inc
packages/gnutls/gnutls/.mtn2git_empty [deleted file]
packages/gnutls/gnutls/configure_madness.patch [deleted file]
packages/gnutls/gnutls/gnutls-openssl.patch [deleted file]
packages/gnutls/gnutls/gnutls-texinfo-euro.patch [deleted file]
packages/gnutls/gnutls_1.6.3.bb

diff --git a/packages/gnutls/gnutls-1.6.3/.mtn2git_empty b/packages/gnutls/gnutls-1.6.3/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/gnutls/gnutls-1.6.3/configure_madness.patch b/packages/gnutls/gnutls-1.6.3/configure_madness.patch
new file mode 100644 (file)
index 0000000..26111df
--- /dev/null
@@ -0,0 +1,22 @@
+Index: gnutls-1.6.3/configure.in
+===================================================================
+--- gnutls-1.6.3.orig/configure.in     2007-05-25 12:28:59.000000000 +0000
++++ gnutls-1.6.3/configure.in  2007-11-13 17:53:23.000000000 +0000
+@@ -574,13 +574,13 @@
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+-LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
+-LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS -I${includedir}"
++LIBGNUTLS_LIBS="-lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
++LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS"
+ AC_SUBST(LIBGNUTLS_LIBS)
+ AC_SUBST(LIBGNUTLS_CFLAGS)
+-LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
+-LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS -I${includedir}"
++LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
++LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS"
+ AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
+ AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
+ export ac_full
diff --git a/packages/gnutls/gnutls-1.6.3/gnutls-openssl.patch b/packages/gnutls/gnutls-1.6.3/gnutls-openssl.patch
new file mode 100644 (file)
index 0000000..e2c1895
--- /dev/null
@@ -0,0 +1,124 @@
+Index: gnutls-1.6.0/libextra/gnutls_openssl.c
+===================================================================
+--- gnutls-1.6.0.orig/libextra/gnutls_openssl.c        2006-08-13 22:34:09.000000000 +0200
++++ gnutls-1.6.0/libextra/gnutls_openssl.c     2006-12-12 15:07:59.002227000 +0100
+@@ -256,12 +256,17 @@
+   ssl->rfd = (gnutls_transport_ptr_t) - 1;
+   ssl->wfd = (gnutls_transport_ptr_t) - 1;
++  ssl->ssl_peek_buffer = NULL;
++  ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
++
+   return ssl;
+ }
+ void
+ SSL_free (SSL * ssl)
+ {
++  if (ssl->ssl_peek_buffer)
++    free(ssl->ssl_peek_buffer);
+   gnutls_certificate_free_credentials (ssl->gnutls_cred);
+   gnutls_deinit (ssl->gnutls_state);
+   free (ssl);
+@@ -285,6 +290,7 @@
+ SSL_set_fd (SSL * ssl, int fd)
+ {
+   gnutls_transport_set_ptr (ssl->gnutls_state, GNUTLS_INT_TO_POINTER (fd));
++  ssl->rfd = ssl->wfd = fd;
+   return 1;
+ }
+@@ -310,6 +316,17 @@
+   return 1;
+ }
++int SSL_get_rfd(SSL *ssl)
++{
++  return ssl->rfd;
++}
++
++int SSL_get_wfd(SSL *ssl)
++{
++  return ssl->wfd;
++}
++
++
+ void
+ SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
+ {
+@@ -325,6 +342,8 @@
+ int
+ SSL_pending (SSL * ssl)
+ {
++  if (ssl->ssl_peek_avail)
++    return ssl->ssl_peek_avail;
+   return gnutls_record_check_pending (ssl->gnutls_state);
+ }
+@@ -480,11 +499,50 @@
+   return 1;
+ }
++int SSL_peek(SSL *ssl, void *buf, int len)
++{
++  if (len > ssl->ssl_peek_buffer_size) {
++    ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
++    ssl->ssl_peek_buffer_size = len;
++  }
++
++  if (ssl->ssl_peek_avail == 0) {
++
++    int ret;
++    
++    ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
++    ssl->last_error = ret;
++    
++    if (ret > 0)
++      ssl->ssl_peek_avail += ret;
++  }
++
++  if (len > ssl->ssl_peek_avail)
++    len = ssl->ssl_peek_avail;
++
++  memcpy (buf, ssl->ssl_peek_buffer, len);
++
++  return len;
++}
++
+ int
+ SSL_read (SSL * ssl, void *buf, int len)
+ {
+   int ret;
++  if (ssl->ssl_peek_avail) {
++    int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
++
++    memcpy (buf, ssl->ssl_peek_buffer, n);
++
++    if (ssl->ssl_peek_avail > n)
++      memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
++
++    ssl->ssl_peek_avail -= n;
++
++    return n;
++  }
++
+   ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
+   ssl->last_error = ret;
+Index: gnutls-1.6.0/includes/gnutls/openssl.h
+===================================================================
+--- gnutls-1.6.0.orig/includes/gnutls/openssl.h        2006-03-08 11:44:58.000000000 +0100
++++ gnutls-1.6.0/includes/gnutls/openssl.h     2006-12-12 15:07:26.032227000 +0100
+@@ -164,6 +164,11 @@
+     gnutls_transport_ptr_t rfd;
+     gnutls_transport_ptr_t wfd;
++
++    char *ssl_peek_buffer;
++    size_t ssl_peek_buffer_size;
++    size_t ssl_peek_avail;
++
+   };
+ #define rbio gnutls_state
diff --git a/packages/gnutls/gnutls-1.6.3/gnutls-texinfo-euro.patch b/packages/gnutls/gnutls-1.6.3/gnutls-texinfo-euro.patch
new file mode 100644 (file)
index 0000000..e2a2762
--- /dev/null
@@ -0,0 +1,16 @@
+The version of texinfo in Debian Sarge does not understand the @euro{} command.
+This patch replaces the @euro{} command with the word "euro".
+
+--- gnutls-1.3.5/doc/signatures.texi.orig      2006-04-26 08:06:40.918268000 +0930
++++ gnutls-1.3.5/doc/signatures.texi   2006-04-26 08:06:52.446515440 +0930
+@@ -11,8 +11,8 @@
+ long as it is difficult enough to generate two different messages with
+ the same hash algorithm output. In that case the same signature could
+ be used as a proof for both messages. Nobody wants to sign an innocent
+-message of donating 1 @euro{} to Greenpeace and find out that he
+-donated 1.000.000 @euro{} to Bad Inc.
++message of donating 1 euro to Greenpeace and find out that he
++donated 1.000.000 euro to Bad Inc.
+ For a hash algorithm to be called cryptographic the following three
+ requirements must hold
index 2211d5f..d08b0ca 100644 (file)
@@ -4,10 +4,7 @@ DEPENDS = "zlib libgcrypt lzo"
 
 LICENSE = "LGPL"
 
-SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2 \
-           file://gnutls-openssl.patch;patch=1 \
-           file://gnutls-texinfo-euro.patch;patch=1 \
-           file://configure_madness.patch;patch=1 "
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2"
 
 inherit autotools binconfig pkgconfig
 
diff --git a/packages/gnutls/gnutls/.mtn2git_empty b/packages/gnutls/gnutls/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/gnutls/gnutls/configure_madness.patch b/packages/gnutls/gnutls/configure_madness.patch
deleted file mode 100644 (file)
index 26111df..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: gnutls-1.6.3/configure.in
-===================================================================
---- gnutls-1.6.3.orig/configure.in     2007-05-25 12:28:59.000000000 +0000
-+++ gnutls-1.6.3/configure.in  2007-11-13 17:53:23.000000000 +0000
-@@ -574,13 +574,13 @@
- AC_LIBTOOL_WIN32_DLL
- AC_PROG_LIBTOOL
--LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
--LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS -I${includedir}"
-+LIBGNUTLS_LIBS="-lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS"
-+LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS"
- AC_SUBST(LIBGNUTLS_LIBS)
- AC_SUBST(LIBGNUTLS_CFLAGS)
--LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
--LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS -I${includedir}"
-+LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LIBOPENCDK_LIBS $LZO_LIBS $LIBGNUTLS_LIBS"
-+LIBGNUTLS_EXTRA_CFLAGS="$LIBOPENCDK_CFLAGS"
- AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
- AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
- export ac_full
diff --git a/packages/gnutls/gnutls/gnutls-openssl.patch b/packages/gnutls/gnutls/gnutls-openssl.patch
deleted file mode 100644 (file)
index e2c1895..0000000
+++ /dev/null
@@ -1,124 +0,0 @@
-Index: gnutls-1.6.0/libextra/gnutls_openssl.c
-===================================================================
---- gnutls-1.6.0.orig/libextra/gnutls_openssl.c        2006-08-13 22:34:09.000000000 +0200
-+++ gnutls-1.6.0/libextra/gnutls_openssl.c     2006-12-12 15:07:59.002227000 +0100
-@@ -256,12 +256,17 @@
-   ssl->rfd = (gnutls_transport_ptr_t) - 1;
-   ssl->wfd = (gnutls_transport_ptr_t) - 1;
-+  ssl->ssl_peek_buffer = NULL;
-+  ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
-+
-   return ssl;
- }
- void
- SSL_free (SSL * ssl)
- {
-+  if (ssl->ssl_peek_buffer)
-+    free(ssl->ssl_peek_buffer);
-   gnutls_certificate_free_credentials (ssl->gnutls_cred);
-   gnutls_deinit (ssl->gnutls_state);
-   free (ssl);
-@@ -285,6 +290,7 @@
- SSL_set_fd (SSL * ssl, int fd)
- {
-   gnutls_transport_set_ptr (ssl->gnutls_state, GNUTLS_INT_TO_POINTER (fd));
-+  ssl->rfd = ssl->wfd = fd;
-   return 1;
- }
-@@ -310,6 +316,17 @@
-   return 1;
- }
-+int SSL_get_rfd(SSL *ssl)
-+{
-+  return ssl->rfd;
-+}
-+
-+int SSL_get_wfd(SSL *ssl)
-+{
-+  return ssl->wfd;
-+}
-+
-+
- void
- SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
- {
-@@ -325,6 +342,8 @@
- int
- SSL_pending (SSL * ssl)
- {
-+  if (ssl->ssl_peek_avail)
-+    return ssl->ssl_peek_avail;
-   return gnutls_record_check_pending (ssl->gnutls_state);
- }
-@@ -480,11 +499,50 @@
-   return 1;
- }
-+int SSL_peek(SSL *ssl, void *buf, int len)
-+{
-+  if (len > ssl->ssl_peek_buffer_size) {
-+    ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
-+    ssl->ssl_peek_buffer_size = len;
-+  }
-+
-+  if (ssl->ssl_peek_avail == 0) {
-+
-+    int ret;
-+    
-+    ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
-+    ssl->last_error = ret;
-+    
-+    if (ret > 0)
-+      ssl->ssl_peek_avail += ret;
-+  }
-+
-+  if (len > ssl->ssl_peek_avail)
-+    len = ssl->ssl_peek_avail;
-+
-+  memcpy (buf, ssl->ssl_peek_buffer, len);
-+
-+  return len;
-+}
-+
- int
- SSL_read (SSL * ssl, void *buf, int len)
- {
-   int ret;
-+  if (ssl->ssl_peek_avail) {
-+    int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
-+
-+    memcpy (buf, ssl->ssl_peek_buffer, n);
-+
-+    if (ssl->ssl_peek_avail > n)
-+      memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
-+
-+    ssl->ssl_peek_avail -= n;
-+
-+    return n;
-+  }
-+
-   ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
-   ssl->last_error = ret;
-Index: gnutls-1.6.0/includes/gnutls/openssl.h
-===================================================================
---- gnutls-1.6.0.orig/includes/gnutls/openssl.h        2006-03-08 11:44:58.000000000 +0100
-+++ gnutls-1.6.0/includes/gnutls/openssl.h     2006-12-12 15:07:26.032227000 +0100
-@@ -164,6 +164,11 @@
-     gnutls_transport_ptr_t rfd;
-     gnutls_transport_ptr_t wfd;
-+
-+    char *ssl_peek_buffer;
-+    size_t ssl_peek_buffer_size;
-+    size_t ssl_peek_avail;
-+
-   };
- #define rbio gnutls_state
diff --git a/packages/gnutls/gnutls/gnutls-texinfo-euro.patch b/packages/gnutls/gnutls/gnutls-texinfo-euro.patch
deleted file mode 100644 (file)
index e2a2762..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-The version of texinfo in Debian Sarge does not understand the @euro{} command.
-This patch replaces the @euro{} command with the word "euro".
-
---- gnutls-1.3.5/doc/signatures.texi.orig      2006-04-26 08:06:40.918268000 +0930
-+++ gnutls-1.3.5/doc/signatures.texi   2006-04-26 08:06:52.446515440 +0930
-@@ -11,8 +11,8 @@
- long as it is difficult enough to generate two different messages with
- the same hash algorithm output. In that case the same signature could
- be used as a proof for both messages. Nobody wants to sign an innocent
--message of donating 1 @euro{} to Greenpeace and find out that he
--donated 1.000.000 @euro{} to Bad Inc.
-+message of donating 1 euro to Greenpeace and find out that he
-+donated 1.000.000 euro to Bad Inc.
- For a hash algorithm to be called cryptographic the following three
- requirements must hold
index a5b5341..ddaef1d 100644 (file)
@@ -1,2 +1,9 @@
 require gnutls.inc
+
+SRC_URI += "\
+       file://gnutls-openssl.patch;patch=1 \
+       file://gnutls-texinfo-euro.patch;patch=1 \
+       file://configure_madness.patch;patch=1 \
+       "
+
 PR = "r3"