gstreamer: add 0.10
authorFelix Domke <tmbinc@elitedvb.ne>
Sat, 18 Mar 2006 17:18:54 +0000 (17:18 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sat, 18 Mar 2006 17:18:54 +0000 (17:18 +0000)
packages/gstreamer/gst-plugins-bad_0.10.1.bb [new file with mode: 0644]
packages/gstreamer/gst-plugins-base_0.10.5.bb [new file with mode: 0644]
packages/gstreamer/gst-plugins-good_0.10.2.bb [new file with mode: 0644]
packages/gstreamer/gst-plugins-ugly_0.10.2.bb [new file with mode: 0644]
packages/gstreamer/gst-plugins.inc [new file with mode: 0644]
packages/gstreamer/gstreamer_0.10.4.bb [new file with mode: 0644]

diff --git a/packages/gstreamer/gst-plugins-bad_0.10.1.bb b/packages/gstreamer/gst-plugins-bad_0.10.1.bb
new file mode 100644 (file)
index 0000000..655f2c1
--- /dev/null
@@ -0,0 +1 @@
+include gst-plugins.inc
diff --git a/packages/gstreamer/gst-plugins-base_0.10.5.bb b/packages/gstreamer/gst-plugins-base_0.10.5.bb
new file mode 100644 (file)
index 0000000..655f2c1
--- /dev/null
@@ -0,0 +1 @@
+include gst-plugins.inc
diff --git a/packages/gstreamer/gst-plugins-good_0.10.2.bb b/packages/gstreamer/gst-plugins-good_0.10.2.bb
new file mode 100644 (file)
index 0000000..655f2c1
--- /dev/null
@@ -0,0 +1 @@
+include gst-plugins.inc
diff --git a/packages/gstreamer/gst-plugins-ugly_0.10.2.bb b/packages/gstreamer/gst-plugins-ugly_0.10.2.bb
new file mode 100644 (file)
index 0000000..655f2c1
--- /dev/null
@@ -0,0 +1 @@
+include gst-plugins.inc
diff --git a/packages/gstreamer/gst-plugins.inc b/packages/gstreamer/gst-plugins.inc
new file mode 100644 (file)
index 0000000..b689ebd
--- /dev/null
@@ -0,0 +1,31 @@
+DESCRIPTION = "Plugins for GStreamer"
+SECTION = "multimedia"
+PRIORITY = "optional"
+MAINTAINER = "Felix Domke <tmbinc@openembedded.org>"
+DEPENDS = "gstreamer libmikmod libmad libogg tremor libvorbis libid3tag"
+PR = "r0"
+
+inherit autotools pkgconfig gconf
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2"
+
+EXTRA_OECONF = "--disable-x --disable-aalib --disable-esd --disable-shout2 \
+               --disable-sdl"
+
+acpaths = "-I ${S}/common/m4 -I ${S}/m4"
+
+LIBV = "0.10"
+
+python populate_packages_prepend () {
+       gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
+       postinst = bb.data.getVar('plugin_postinst', d, 1)
+
+       do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst)
+       do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)')
+}
+
+do_stage() {
+       autotools_stage_all
+}
+
+ALLOW_EMPTY = "1"
diff --git a/packages/gstreamer/gstreamer_0.10.4.bb b/packages/gstreamer/gstreamer_0.10.4.bb
new file mode 100644 (file)
index 0000000..1fd2d14
--- /dev/null
@@ -0,0 +1,28 @@
+DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
+It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
+SECTION = "multimedia"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+HOMEPAGE = "http://www.gstreamer.net/"
+MAINTAINER = "Felix Domke <tmbinc@openembedded.org>"
+DEPENDS = "glib-2.0 gettext-native popt"
+
+PR = "r0"
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2"
+EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no"
+
+do_stage() {
+       oe_runmake install prefix=${STAGING_DIR} \
+              bindir=${STAGING_BINDIR} \
+              includedir=${STAGING_INCDIR} \
+              libdir=${STAGING_LIBDIR} \
+              datadir=${STAGING_DATADIR} \
+              mandir=${STAGING_DIR}/share/man
+}
+
+FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"