watchdog: package version 5.4
authorJeremy Lainé <jeremy.laine@m4x.org>
Mon, 26 Jan 2009 15:17:58 +0000 (16:17 +0100)
committerJeremy Lainé <jeremy.laine@m4x.org>
Mon, 26 Jan 2009 15:17:58 +0000 (16:17 +0100)
* update watchdog to version 5.4
* add an init script for watchdog

packages/watchdog/files/init [new file with mode: 0644]
packages/watchdog/watchdog_5.4.bb [new file with mode: 0644]

diff --git a/packages/watchdog/files/init b/packages/watchdog/files/init
new file mode 100644 (file)
index 0000000..f42797e
--- /dev/null
@@ -0,0 +1,33 @@
+#!/bin/sh
+DAEMON="/usr/sbin/watchdog"
+NAME="watchdog"
+DESC="watchdog daemon"
+OPTIONS=""
+
+test -f $DAEMON || exit 0
+
+case "$1" in
+    start)
+        echo -n "Starting $DESC: $NAME... "
+        start-stop-daemon -S -x $DAEMON -- $OPTIONS
+        echo "done."
+       ;;
+    stop)
+        echo -n "Stopping $DESC: $NAME... "
+        start-stop-daemon -K -x $DAEMON
+        echo "done."
+        ;;
+    restart)
+        echo "Restarting $DESC: $NAME... "
+        $0 stop
+        sleep 1
+        $0 start
+        echo "done."
+        ;;
+    *)
+        echo "Usage: $0 {start|stop|restart}"
+        exit 1
+        ;;
+esac
+
+exit 0
diff --git a/packages/watchdog/watchdog_5.4.bb b/packages/watchdog/watchdog_5.4.bb
new file mode 100644 (file)
index 0000000..ec4cea4
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "System watchdog daemon"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${PN}-${PV}.tar.gz \
+       file://init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "watchdog"
+INITSCRIPT_PARAMS = "defaults 10"
+
+do_install_append() {
+       install -d ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/watchdog
+}
+