subversion: Build with the latest libtool.
authorStanislav Brabec <utx@penguin.cz>
Thu, 30 Apr 2009 21:33:36 +0000 (21:33 +0000)
committerutx@penguin.cz <utx@penguin.cz>
Thu, 30 Apr 2009 21:33:36 +0000 (21:33 +0000)
recipes/subversion/files/libtool.patch [new file with mode: 0644]
recipes/subversion/subversion_1.4.5.bb

diff --git a/recipes/subversion/files/libtool.patch b/recipes/subversion/files/libtool.patch
new file mode 100644 (file)
index 0000000..d296806
--- /dev/null
@@ -0,0 +1,12 @@
+Index: subversion-1.4.5/configure.in
+===================================================================
+--- subversion-1.4.5.orig/configure.in 2007-01-01 14:41:51.000000000 +0000
++++ subversion-1.4.5/configure.in      2009-04-30 21:19:12.000000000 +0000
+@@ -11,6 +11,7 @@
+ AC_CONFIG_SRCDIR(subversion/include/svn_types.h)
+ AC_CONFIG_AUX_DIR([build])
++AC_CONFIG_MACRO_DIR([build/ac-macros])
+ AC_MSG_NOTICE([Configuring Subversion ]AC_PACKAGE_VERSION)
index d4f2905..1029e70 100644 (file)
@@ -9,7 +9,8 @@ PR = "r0"
 
 SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
            file://disable-revision-install.patch;patch=1 \
-          file://neon-detection.patch;patch=1"
+          file://neon-detection.patch;patch=1 \
+          file://libtool.patch;patch=1"
 
 EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
                 --without-berkeley-db --without-apxs --without-apache \
@@ -23,6 +24,14 @@ export LDFLAGS += " -L${STAGING_LIBDIR} "
 
 acpaths = "-I build/ -I build/ac-macros/"
 
+# FIXME: Ugly hack! Instead of fully porting to the new libtool, apply libtool.patch and do the rest here.
+do_configure_prepend() {
+       rm -f build/libtool.m4
+}
+do_configure_append() {
+       if ! test -f libtool ; then cp -a *-libtool libtool ; fi
+}
+
 do_stage() {
        autotools_stage_all
 }