fakeroot: upgrade to 1.8.3 upstream version
authorMike Westerhof <mwester@dls.net>
Wed, 31 Oct 2007 06:02:56 +0000 (06:02 +0000)
committerMike Westerhof <mwester@dls.net>
Wed, 31 Oct 2007 06:02:56 +0000 (06:02 +0000)
packages/fakeroot/fakeroot-1.8.3/.mtn2git_empty [new file with mode: 0644]
packages/fakeroot/fakeroot-1.8.3/configure-libtool.patch [new file with mode: 0644]
packages/fakeroot/fakeroot-native-1.8.3/.mtn2git_empty [new file with mode: 0644]
packages/fakeroot/fakeroot-native-1.8.3/configure-libtool.patch [new file with mode: 0644]
packages/fakeroot/fakeroot-native_1.8.3.bb [new file with mode: 0644]
packages/fakeroot/fakeroot_1.8.3.bb [new file with mode: 0644]

diff --git a/packages/fakeroot/fakeroot-1.8.3/.mtn2git_empty b/packages/fakeroot/fakeroot-1.8.3/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/fakeroot/fakeroot-1.8.3/configure-libtool.patch b/packages/fakeroot/fakeroot-1.8.3/configure-libtool.patch
new file mode 100644 (file)
index 0000000..8830328
--- /dev/null
@@ -0,0 +1,18 @@
+--- fakeroot-1.8.3/configure.ac.orig   2007-10-31 00:17:27.000000000 -0500
++++ fakeroot-1.8.3/configure.ac        2007-10-31 00:18:12.000000000 -0500
+@@ -1,14 +1,12 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
+ AC_PREREQ(2.61)
+-LT_PREREQ(2.1a)
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE
+ AM_MAINTAINER_MODE
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+-LT_INIT
+-LT_LANG(C)
++AC_PROG_LIBTOOL
+ AC_ARG_WITH([ipc],
+           AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],
diff --git a/packages/fakeroot/fakeroot-native-1.8.3/.mtn2git_empty b/packages/fakeroot/fakeroot-native-1.8.3/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/fakeroot/fakeroot-native-1.8.3/configure-libtool.patch b/packages/fakeroot/fakeroot-native-1.8.3/configure-libtool.patch
new file mode 100644 (file)
index 0000000..8830328
--- /dev/null
@@ -0,0 +1,18 @@
+--- fakeroot-1.8.3/configure.ac.orig   2007-10-31 00:17:27.000000000 -0500
++++ fakeroot-1.8.3/configure.ac        2007-10-31 00:18:12.000000000 -0500
+@@ -1,14 +1,12 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
+ AC_PREREQ(2.61)
+-LT_PREREQ(2.1a)
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE
+ AM_MAINTAINER_MODE
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+-LT_INIT
+-LT_LANG(C)
++AC_PROG_LIBTOOL
+ AC_ARG_WITH([ipc],
+           AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],
diff --git a/packages/fakeroot/fakeroot-native_1.8.3.bb b/packages/fakeroot/fakeroot-native_1.8.3.bb
new file mode 100644 (file)
index 0000000..8b3d2a1
--- /dev/null
@@ -0,0 +1,20 @@
+SECTION = "base"
+require fakeroot_${PV}.bb
+inherit native
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 "
+S = "${WORKDIR}/fakeroot-${PV}"
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+    if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+        bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+    oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+
diff --git a/packages/fakeroot/fakeroot_1.8.3.bb b/packages/fakeroot/fakeroot_1.8.3.bb
new file mode 100644 (file)
index 0000000..ef4d1ba
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "Gives a fake root environment"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.debian.org/debian/pool/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+           file://configure-libtool.patch;patch=1"
+           
+inherit autotools
+
+do_stage() {
+        install -d ${STAGING_INCDIR}/fakeroot
+        install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+        autotools_stage_all
+}