linux-linux-headers: add 2.6.22
authorKoen Kooi <koen@openembedded.org>
Sun, 12 Aug 2007 08:39:32 +0000 (08:39 +0000)
committerKoen Kooi <koen@openembedded.org>
Sun, 12 Aug 2007 08:39:32 +0000 (08:39 +0000)
packages/linux-libc-headers/linux-libc-headers-2.6.22/.mtn2git_empty [new file with mode: 0644]
packages/linux-libc-headers/linux-libc-headers-2.6.22/procinfo.h [new file with mode: 0644]
packages/linux-libc-headers/linux-libc-headers_2.6.22.bb [new file with mode: 0644]

diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.22/.mtn2git_empty b/packages/linux-libc-headers/linux-libc-headers-2.6.22/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.22/procinfo.h b/packages/linux-libc-headers/linux-libc-headers-2.6.22/procinfo.h
new file mode 100644 (file)
index 0000000..8cdf828
--- /dev/null
@@ -0,0 +1,24 @@
+/*
+ *  linux/include/asm-arm/procinfo.h
+ *
+ *  Copyright (C) 1996-1999 Russell King
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ */
+#ifndef __ASM_PROCINFO_H
+#define __ASM_PROCINFO_H
+
+#define HWCAP_SWP      1
+#define HWCAP_HALF     2
+#define HWCAP_THUMB    4
+#define HWCAP_26BIT    8       /* Play it safe */
+#define HWCAP_FAST_MULT        16
+#define HWCAP_FPA      32
+#define HWCAP_VFP      64
+#define HWCAP_EDSP     128
+#define HWCAP_JAVA     256
+#define HWCAP_IWMMXT   512
+#define HWCAP_CRUNCH   1024
+#endif
diff --git a/packages/linux-libc-headers/linux-libc-headers_2.6.22.bb b/packages/linux-libc-headers/linux-libc-headers_2.6.22.bb
new file mode 100644 (file)
index 0000000..97e5a22
--- /dev/null
@@ -0,0 +1,73 @@
+require linux-libc-headers.inc
+
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS = "unifdef-native"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+           file://procinfo.h"
+
+S = "${WORKDIR}/linux-${PV}"
+
+set_arch() {
+       case ${TARGET_ARCH} in
+               alpha*)   ARCH=alpha ;;
+               arm*)     ARCH=arm ;;
+               cris*)    ARCH=cris ;;
+               hppa*)    ARCH=parisc ;;
+               i*86*)    ARCH=i386 ;;
+               ia64*)    ARCH=ia64 ;;
+               mips*)    ARCH=mips ;;
+               m68k*)    ARCH=m68k ;;
+               powerpc*) ARCH=powerpc ;;
+               s390*)    ARCH=s390 ;;
+               sh*)      ARCH=sh ;;
+               sparc64*) ARCH=sparc64 ;;
+               sparc*)   ARCH=sparc ;;
+               x86_64*)  ARCH=x86_64 ;;
+               avr32*)   ARCH=avr32 ;;
+                bfin*)    ARCH=blackfin ;;
+       esac
+}
+
+do_configure() {
+       set_arch
+       oe_runmake allnoconfig ARCH=$ARCH
+}
+
+do_compile () {
+}
+
+do_install() {
+       set_arch
+       oe_runmake headers_install INSTALL_HDR_PATH=${D}/usr ARCH=$ARCH
+}
+
+do_install_append_arm() {
+       cp ${WORKDIR}/procinfo.h ${D}${includedir}/asm/
+}
+
+STAGE_TEMP="${WORKDIR}/temp-staging"
+
+do_stage () {
+       set_arch
+       echo $ARCH
+       rm -rf ${STAGE_TEMP}
+       mkdir -p ${STAGE_TEMP}
+       oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}/usr ARCH=$ARCH
+       if [ "$ARCH" = "arm" ]; then
+               cp ${WORKDIR}/procinfo.h ${STAGE_TEMP}${includedir}/asm/
+       fi
+       install -d ${STAGING_INCDIR}
+       rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
+       cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
+       cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
+       cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
+       rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
+       rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
+       rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm-generic
+       install -d ${CROSS_DIR}/${TARGET_SYS}/include
+       cp -pfLR ${STAGE_TEMP}${includedir}/linux ${CROSS_DIR}/${TARGET_SYS}/include/
+       cp -pfLR ${STAGE_TEMP}${includedir}/asm ${CROSS_DIR}/${TARGET_SYS}/include/
+       cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${CROSS_DIR}/${TARGET_SYS}/include/
+}