libpam: update to 1.0.2
authorKoen Kooi <koen@openembedded.org>
Fri, 5 Sep 2008 13:36:58 +0000 (13:36 +0000)
committerKoen Kooi <koen@openembedded.org>
Fri, 5 Sep 2008 13:36:58 +0000 (13:36 +0000)
packages/pam/libpam-1.0.2/.mtn2git_empty [new file with mode: 0644]
packages/pam/libpam-1.0.2/pam-nodocs.patch [new file with mode: 0644]
packages/pam/libpam_0.79.bb
packages/pam/libpam_1.0.2.bb [new file with mode: 0644]

diff --git a/packages/pam/libpam-1.0.2/.mtn2git_empty b/packages/pam/libpam-1.0.2/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/pam/libpam-1.0.2/pam-nodocs.patch b/packages/pam/libpam-1.0.2/pam-nodocs.patch
new file mode 100644 (file)
index 0000000..895f0e1
--- /dev/null
@@ -0,0 +1,35 @@
+--- /tmp/Makefile.am   2008-09-05 15:16:21.000000000 +0200
++++ Linux-PAM-1.0.2/Makefile.am        2008-09-05 15:16:56.153198000 +0200
+@@ -5,9 +5,9 @@
+ AUTOMAKE_OPTIONS = 1.9 gnu dist-bzip2 check-news
+ if STATIC_MODULES
+-SUBDIRS = modules libpam libpamc libpam_misc tests po conf doc examples xtests
++SUBDIRS = modules libpam libpamc libpam_misc tests po conf examples xtests
+ else
+-SUBDIRS = libpam tests libpamc libpam_misc modules po conf doc examples xtests
++SUBDIRS = libpam tests libpamc libpam_misc modules po conf examples xtests
+ endif
+ CLEANFILES = *~
+@@ -28,19 +28,7 @@
+ ACLOCAL_AMFLAGS = -I m4
+-release: dist releasedocs
+-
+-release-docs: releasedocs
+-
+-releasedocs:
+-      rm -rf Linux-PAM-$(VERSION)
+-      mkdir -p Linux-PAM-$(VERSION)/doc
+-      make -C doc releasedocs
+-      tar zfc Linux-PAM-$(VERSION)-docs.tar.gz \
+-              Linux-PAM-$(VERSION)/doc
+-      tar jfc Linux-PAM-$(VERSION)-docs.tar.bz2 \
+-              Linux-PAM-$(VERSION)/doc
+-      rm -rf Linux-PAM-$(VERSION)
++release: dist 
+ xtests:
+       make -C xtests xtests
index 14dab42..c695f47 100644 (file)
@@ -52,11 +52,7 @@ LEAD_SONAME = "libpam.so.*"
 FILES_${PN} += "/usr/lib/security/pam_*.so /usr/lib/security/pam_filter/*"
 
 do_stage() {
-       autotools_stage_includes
-       for lib in libpam libpamc libpam_misc
-       do
-               oe_libinstall -so -C "$lib" "$lib" ${STAGING_LIBDIR}
-       done
+       autotools_stage_all
 }
 
 # An attempt to build on uclibc will fail, causing annoyance,
diff --git a/packages/pam/libpam_1.0.2.bb b/packages/pam/libpam_1.0.2.bb
new file mode 100644 (file)
index 0000000..cf98944
--- /dev/null
@@ -0,0 +1,40 @@
+DESCRIPTION = "\
+PAM authentication library for Linux.  \
+Linux-PAM (Pluggable Authentication Modules for Linux) is a \
+library that enables the local system administrator to choose \
+how individual applications authenticate users. For an \
+overview of the Linux-PAM library see the Linux-PAM System \
+Administrators' Guide."
+HOMEPAGE = "http://kernel.org/pub/linux/libs/pam"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+
+# The project is actually called Linux-PAM but that gives
+# a bad OE package name because of the upper case characters
+pn = "Linux-PAM"
+p = "${pn}-${PV}"
+S = "${WORKDIR}/${p}"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/pam/library/${p}.tar.bz2 \
+           file://pam-nodocs.patch;patch=1 "
+
+inherit autotools
+
+LEAD_SONAME = "libpam.so.*"
+
+python populate_packages_prepend () {
+        pam_libdir    = bb.data.expand('${libdir}/security', d)
+       pam_libdirdebug = bb.data.expand('${libdir}/security/.debug', d)
+        pam_filterdir = bb.data.expand('${libdir}/security/pam_filter', d)
+       do_split_packages(d, pam_libdir, '^pam(.*)\.so$', 'pam-plugin%s', 'PAM plugin for %s', extra_depends='')
+        do_split_packages(d, pam_libdir, '^pam(.*)\.la$', 'pam-plugin%s-dev', 'PAM plugin for %s dev', extra_depends='')
+       do_split_packages(d, pam_libdirdebug, '^pam(.*)\.so$', 'pam-plugin%s-dbg', 'PAM plugin for %s debugging symbols', extra_depends='')
+       do_split_packages(d, pam_filterdir, '^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
+}
+
+
+do_stage() {
+       autotools_stage_all
+}
+