mb-applet-task: add a task switcher applet for matchbox-panel
authorKoen Kooi <koen@openembedded.org>
Sat, 25 Mar 2006 16:41:55 +0000 (16:41 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sat, 25 Mar 2006 16:41:55 +0000 (16:41 +0000)
packages/matchbox-applet-tasks/.mtn2git_empty [new file with mode: 0644]
packages/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb [new file with mode: 0644]

diff --git a/packages/matchbox-applet-tasks/.mtn2git_empty b/packages/matchbox-applet-tasks/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb b/packages/matchbox-applet-tasks/mb-applet-tasks_1.0.0.bb
new file mode 100644 (file)
index 0000000..c8e2ff3
--- /dev/null
@@ -0,0 +1,28 @@
+DESCRIPTION = "Tasks applet switcher for matchbox"
+LICENSE = "GPLv2"
+MAINTAINER = "Koen Kooi <koen@dominion.kabel.utwente.nl"
+DEPENDS = "gtk+ libwnck libmatchbox"
+
+CFLAGS += "-I${STAGING_INCDIR} \
+          -I${STAGING_INCDIR}/gtk-2.0 \
+          -I${STAGING_INCDIR}/glib-2.0 \
+          -I${STAGING_INCDIR}/freetype2 \
+          -I${STAGING_INCDIR}/atk-1.0 \
+          -I${STAGING_INCDIR}/libwnck-1.0 \    
+          -I${STAGING_LIBDIR}/gtk-2.0/include \
+          -I${STAGING_INCDIR}/cairo \
+          -DWNCK_I_KNOW_THIS_IS_UNSTABLE"
+
+SRC_URI = "http://mail.pdaxrom.org/1.1.0beta1/src/${P}.tar.bz2"
+
+do_install() {
+install -d ${D}/${datadir}/applications
+install -m 755 mb-applet-tasks ${D}/${bindir}
+install -m 644 mb-applet-tasks.desktop ${D}/${datadir}/applications
+}
+
+
+
+
+
+