python-pydirectfb: commit missing patch
authorMichael Lauer <mickey@vanille-media.de>
Tue, 11 Dec 2007 12:41:43 +0000 (12:41 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Tue, 11 Dec 2007 12:41:43 +0000 (12:41 +0000)
packages/python/python-pydirectfb/.mtn2git_empty [new file with mode: 0644]
packages/python/python-pydirectfb/fix-directfb-detection.patch [new file with mode: 0644]

diff --git a/packages/python/python-pydirectfb/.mtn2git_empty b/packages/python/python-pydirectfb/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/python/python-pydirectfb/fix-directfb-detection.patch b/packages/python/python-pydirectfb/fix-directfb-detection.patch
new file mode 100644 (file)
index 0000000..c8b7cc8
--- /dev/null
@@ -0,0 +1,16 @@
+Index: pydirectfb/setup.py
+===================================================================
+--- pydirectfb.orig/setup.py
++++ pydirectfb/setup.py
+@@ -11,9 +11,10 @@
+     Check dependencies add add the flags to include_dirs, library_dirs and
+     libraries. The basic logic is taken from pygame.
+     """
+-    command = name + '-config --version --cflags --libs 2>/dev/null'
++    command = 'pkg-config %s --modversion --cflags --libs 2>/dev/null' % name
+     try:
+         config = os.popen(command).readlines()
++        print config
+         if len(config) == 0:
+             raise ValueError, 'command not found'
+         flags  = (' '.join(config[1:]) + ' ').split()