fsodeviced: fix parsing error and disable accel and rfkill
authorKlaus Kurzmann <mok@fluxnetz.de>
Fri, 8 Jan 2010 23:32:55 +0000 (00:32 +0100)
committerKlaus Kurzmann <mok@fluxnetz.de>
Fri, 8 Jan 2010 23:32:55 +0000 (00:32 +0100)
in om-gta02 config as fsodeviced segfaults with one of
those two enabled.

Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
recipes/freesmartphone/fsodeviced/fsodeviced.conf
recipes/freesmartphone/fsodeviced_git.bb

index 4e72778..0d7b43a 100644 (file)
@@ -17,17 +17,17 @@ log_destination = /var/log/fsodeviced.log
 
 [fsodevice.accelerometer]
 # Which accelerometer variant plugin to use: none (default), lis302
-device_type = lis302
-
-[fsodevice.accelerometer_lis302]
-# Which input node to read from
-inputnode = /input/event2
-# How many samples to process, when in use
-sample_rate = 100
-# Threshhold to program, when in use
-threshold = 100
-# Scale to program, when in use
-full_scale = 2.3
+#device_type = lis302
+
+#[fsodevice.accelerometer_lis302]
+## Which input node to read from
+#inputnode = /input/event2
+## How many samples to process, when in use
+#sample_rate = 100
+## Threshhold to program, when in use
+#threshold = 100
+## Scale to program, when in use
+#full_scale = 2.3
 
 [fsodevice.player_alsa]
 # No settings yet
@@ -51,7 +51,7 @@ player_type = alsa
 [fsodevice.kernel26_powersupply]
 # No settings yet
 
-[fsodevice.kernel26_rfkill]
+#[fsodevice.kernel26_rfkill]
 # No settings yet
 
 [fsodevice.kernel26_rtc]
index 69c948f..640f9d9 100644 (file)
@@ -27,7 +27,4 @@ do_install_append() {
        install -m 0644 ${WORKDIR}/fsodeviced.conf ${D}${sysconfdir}/freesmartphone/
 }
 
-FILES_${PN} += "
-       ${sysconfdir}/init.d/fsodeviced \
-       ${sysconfdir}/freesmartphone/fsodeviced.conf \
-"
+FILES_${PN} += "${sysconfdir}/init.d/fsodeviced ${sysconfdir}/freesmartphone/fsodeviced.conf"