[iotop] Actually remove the site.py and site.pyo from the package
authorHolger Hans Peter Freyther <zecke@openmoko.org>
Wed, 23 Jul 2008 05:19:00 +0000 (07:19 +0200)
committerHolger Freyther <ich@tamarin.(none)>
Wed, 15 Oct 2008 16:53:39 +0000 (18:53 +0200)
    Use do_install_append instead of _prepend... to remove the files
    that are provided by setuptools as well.

packages/iotop/iotop_0.2.1.bb

index 9d4d93c..5f85f59 100644 (file)
@@ -1,6 +1,6 @@
 HOMEPAGE = "http://guichaz.free.fr/iotop/"
 LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
 
 RDEPENDS = "python-distutils python-curses python-setuptools python-textutils"
 
@@ -8,7 +8,7 @@ SRC_URI = "http://guichaz.free.fr/iotop/files/${PN}-${PV}.tar.bz2"
 
 inherit distutils
 
-do_install_prepend() {
+do_install_append() {
     rm -f ${D}${libdir}/${PYTHON_DIR}/site-packages/site.pyo
     rm -f ${D}${libdir}/${PYTHON_DIR}/site-packages/site.py
 }