sqlite3:
authorHolger Freyther <zecke@selfish.org>
Mon, 11 Jul 2005 17:02:12 +0000 (17:02 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Mon, 11 Jul 2005 17:02:12 +0000 (17:02 +0000)
    -Update from version 3.2.1 to 3.2.2

packages/sqlite/sqlite3-3.2.1/.mtn2git_empty [deleted file]
packages/sqlite/sqlite3-3.2.1/cross-compile.patch [deleted file]
packages/sqlite/sqlite3-3.2.1/ldflags.patch [deleted file]
packages/sqlite/sqlite3-3.2.1/libtool.patch [deleted file]
packages/sqlite/sqlite3-3.2.2/.mtn2git_empty [new file with mode: 0644]
packages/sqlite/sqlite3-3.2.2/cross-compile.patch [new file with mode: 0644]
packages/sqlite/sqlite3-3.2.2/ldflags.patch [new file with mode: 0644]
packages/sqlite/sqlite3-3.2.2/libtool.patch [new file with mode: 0644]
packages/sqlite/sqlite3_3.2.1.bb [deleted file]
packages/sqlite/sqlite3_3.2.2.bb [new file with mode: 0644]

diff --git a/packages/sqlite/sqlite3-3.2.1/.mtn2git_empty b/packages/sqlite/sqlite3-3.2.1/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/sqlite/sqlite3-3.2.1/cross-compile.patch b/packages/sqlite/sqlite3-3.2.1/cross-compile.patch
deleted file mode 100644 (file)
index aaafaa5..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
-Index: sqlite-3.2.1/configure.ac
-===================================================================
---- sqlite-3.2.1.orig/configure.ac     2005-03-23 17:08:39.000000000 +0100
-+++ sqlite-3.2.1/configure.ac  2005-04-25 23:02:40.000000000 +0200
-@@ -186,10 +186,11 @@
- default_build_cflags="-g"
- if test "$config_BUILD_CC" = ""; then
-   AC_PROG_CC
--  if test "$cross_compiling" = "yes"; then
--    AC_MSG_ERROR([unable to find a compiler for building build tools])
--  fi
--  BUILD_CC=$CC
-+#  if test "$cross_compiling" = "yes"; then
-+#    AC_MSG_ERROR([unable to find a compiler for building build tools])
-+#  fi
-+#  BUILD_CC=$CC
-+  BUILD_CC=gcc
-   default_build_cflags=$CFLAGS
- else
-   BUILD_CC=$config_BUILD_CC
-@@ -539,55 +540,14 @@
- # Figure out what C libraries are required to compile programs
- # that use "readline()" library.
- #
--if test "$config_TARGET_READLINE_LIBS" != ""; then
--  TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
--else
--  CC=$TARGET_CC
--  LIBS=""
--  AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
--  AC_CHECK_LIB([readline], [readline])
--  TARGET_READLINE_LIBS="$LIBS"
--fi
-+TARGET_READLINE_LIBS="-lreadline"
- AC_SUBST(TARGET_READLINE_LIBS)
- ##########
- # Figure out where to get the READLINE header files.
- #
--AC_MSG_CHECKING([readline header files])
--found=no
--if test "$config_TARGET_READLINE_INC" != ""; then
--  TARGET_READLINE_INC=$config_TARGET_READLINE_INC
--  found=yes
--fi
--if test "$found" = "yes"; then
--  AC_MSG_RESULT($TARGET_READLINE_INC)
--else
--  AC_MSG_RESULT(not specified: still searching...)
--  AC_CHECK_HEADER(readline.h, [found=yes])
--fi
--if test "$found" = "no"; then
--  for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
--    AC_CHECK_FILE($dir/include/readline.h, found=yes)
--    if test "$found" = "yes"; then
--      TARGET_READLINE_INC="-I$dir/include"
--      break
--    fi
--    AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
--    if test "$found" = "yes"; then
--      TARGET_READLINE_INC="-I$dir/include/readline"
--      break
--    fi
--  done
--fi
--if test "$found" = "yes"; then
--  if test "$TARGET_READLINE_LIBS" = ""; then
--    TARGET_HAVE_READLINE=0
--  else
--    TARGET_HAVE_READLINE=1
--  fi
--else
--  TARGET_HAVE_READLINE=0
--fi
-+TARGET_READLINE_INC=""
-+TARGET_HAVE_READLINE=1
- AC_SUBST(TARGET_READLINE_INC)
- AC_SUBST(TARGET_HAVE_READLINE)
diff --git a/packages/sqlite/sqlite3-3.2.1/ldflags.patch b/packages/sqlite/sqlite3-3.2.1/ldflags.patch
deleted file mode 100644 (file)
index cdc1c51..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-Index: sqlite-3.2.1/Makefile.in
-===================================================================
---- sqlite-3.2.1.orig/Makefile.in      2005-04-25 23:12:10.000000000 +0200
-+++ sqlite-3.2.1/Makefile.in   2005-04-25 23:17:39.000000000 +0200
-@@ -31,6 +31,10 @@
- #
- TCC = @TARGET_CC@ @TARGET_CFLAGS@ -I. -I${TOP}/src
-+# OE overrides
-+#
-+TARGET_LFLAGS = @TARGET_LFLAGS@
-+
- # Define -DNDEBUG to compile without debugging (i.e., for production usage)
- # Omitting the define will cause extra debugging code to be inserted and
- # includes extra comments when "EXPLAIN stmt" is used.
-@@ -228,17 +232,17 @@
-           | awk '{print $$5,$$6}' >last_change
- libsqlite3.la:        $(LIBOBJ)
--      $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(LIBPTHREAD) \
-+      $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(TARGET_LFLAGS) $(LIBPTHREAD) \
-               ${ALLOWRELEASE} -rpath $(libdir) -version-info "8:6:8"
- libtclsqlite3.la:     tclsqlite.lo libsqlite3.la
-       $(LTLINK) -o libtclsqlite3.la tclsqlite.lo \
--              $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(LIBPTHREAD) \
-+              $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(TARGET_LFLAGS) $(LIBPTHREAD) \
-                 -rpath $(libdir)/sqlite \
-               -version-info "8:6:8"
- sqlite3$(TEXE):       $(TOP)/src/shell.c libsqlite3.la sqlite3.h
--      $(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \
-+      $(LTLINK) $(TARGET_LFLAGS) $(READLINE_FLAGS) $(LIBPTHREAD) \
-               -o sqlite3 $(TOP)/src/shell.c libsqlite3.la $(LIBREADLINE)
- # This target creates a directory named "tsrc" and fills it with
-@@ -413,19 +417,19 @@
- tclsqlite3:   tclsqlite-shell.lo libsqlite3.la
-       $(LTLINK) -o tclsqlite3 tclsqlite-shell.lo \
--               libsqlite3.la $(LIBTCL)
-+               libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
- testfixture$(TEXE):   $(TOP)/src/tclsqlite.c libtclsqlite3.la libsqlite3.la $(TESTSRC)
-       $(LTLINK) -DTCLSH=1 -DSQLITE_TEST=1\
-                 $(THREADSAFE) $(TEMP_STORE)\
-                 -o testfixture $(TESTSRC) $(TOP)/src/tclsqlite.c \
--              libtclsqlite3.la $(LIBTCL)
-+              libtclsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
- crashtest$(TEXE):     $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC) $(TOP)/src/os_test.c
-       $(LTLINK) -DOS_TEST=1 -DTCLSH=1 -DSQLITE_TEST=1 \
-               -o crashtest \
-               $(TESTSRC) $(TOP)/src/os_test.c $(TOP)/src/tclsqlite.c \
--              libsqlite3.la $(LIBTCL) $(THREADLIB)
-+              libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL) $(THREADLIB)
-Index: sqlite-3.2.1/configure.ac
-===================================================================
---- sqlite-3.2.1.orig/configure.ac     2005-04-25 23:12:10.000000000 +0200
-+++ sqlite-3.2.1/configure.ac  2005-04-25 23:12:46.000000000 +0200
-@@ -238,6 +238,13 @@
-   TARGET_LINK=$config_TARGET_LINK
- fi
- AC_MSG_RESULT($TARGET_LINK)
-+AC_MSG_CHECKING([switches on the target linker])
-+if test "$config_TARGET_LFLAGS" != ""; then
-+  TARGET_LFLAGS=$config_TARGET_LFLAGS
-+else
-+  TARGET_LFLAGS=$BUILD_LFLAGS
-+fi
-+AC_MSG_RESULT($TARGET_LFLAGS)
- AC_MSG_CHECKING([switches on the target compiler])
- if test "$config_TARGET_TFLAGS" != ""; then
-   TARGET_TFLAGS=$config_TARGET_TFLAGS
diff --git a/packages/sqlite/sqlite3-3.2.1/libtool.patch b/packages/sqlite/sqlite3-3.2.1/libtool.patch
deleted file mode 100644 (file)
index ccf9993..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: sqlite-3.2.1/Makefile.in
-===================================================================
---- sqlite-3.2.1.orig/Makefile.in      2005-03-23 17:09:39.000000000 +0100
-+++ sqlite-3.2.1/Makefile.in   2005-04-25 23:11:20.000000000 +0200
-@@ -15,7 +15,10 @@
- # The toplevel directory of the source tree.  This is the directory
- # that contains this "Makefile.in" and the "configure.in" script.
- #
--TOP = @srcdir@
-+TOP = $(srcdir)
-+srcdir = @srcdir@
-+top_srcdir = @top_srcdir@
-+top_builddir = .
- # C Compiler and options for use in building executables that
- # will run on the platform that is doing the build.
-@@ -96,7 +99,7 @@
- exec_prefix = @exec_prefix@
- libdir = @libdir@
- INSTALL = @INSTALL@
--LIBTOOL = ./libtool
-+LIBTOOL = @LIBTOOL@
- ALLOWRELEASE = @ALLOWRELEASE@
- # libtool compile/link/install
diff --git a/packages/sqlite/sqlite3-3.2.2/.mtn2git_empty b/packages/sqlite/sqlite3-3.2.2/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/sqlite/sqlite3-3.2.2/cross-compile.patch b/packages/sqlite/sqlite3-3.2.2/cross-compile.patch
new file mode 100644 (file)
index 0000000..aaafaa5
--- /dev/null
@@ -0,0 +1,84 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: sqlite-3.2.1/configure.ac
+===================================================================
+--- sqlite-3.2.1.orig/configure.ac     2005-03-23 17:08:39.000000000 +0100
++++ sqlite-3.2.1/configure.ac  2005-04-25 23:02:40.000000000 +0200
+@@ -186,10 +186,11 @@
+ default_build_cflags="-g"
+ if test "$config_BUILD_CC" = ""; then
+   AC_PROG_CC
+-  if test "$cross_compiling" = "yes"; then
+-    AC_MSG_ERROR([unable to find a compiler for building build tools])
+-  fi
+-  BUILD_CC=$CC
++#  if test "$cross_compiling" = "yes"; then
++#    AC_MSG_ERROR([unable to find a compiler for building build tools])
++#  fi
++#  BUILD_CC=$CC
++  BUILD_CC=gcc
+   default_build_cflags=$CFLAGS
+ else
+   BUILD_CC=$config_BUILD_CC
+@@ -539,55 +540,14 @@
+ # Figure out what C libraries are required to compile programs
+ # that use "readline()" library.
+ #
+-if test "$config_TARGET_READLINE_LIBS" != ""; then
+-  TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
+-else
+-  CC=$TARGET_CC
+-  LIBS=""
+-  AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
+-  AC_CHECK_LIB([readline], [readline])
+-  TARGET_READLINE_LIBS="$LIBS"
+-fi
++TARGET_READLINE_LIBS="-lreadline"
+ AC_SUBST(TARGET_READLINE_LIBS)
+ ##########
+ # Figure out where to get the READLINE header files.
+ #
+-AC_MSG_CHECKING([readline header files])
+-found=no
+-if test "$config_TARGET_READLINE_INC" != ""; then
+-  TARGET_READLINE_INC=$config_TARGET_READLINE_INC
+-  found=yes
+-fi
+-if test "$found" = "yes"; then
+-  AC_MSG_RESULT($TARGET_READLINE_INC)
+-else
+-  AC_MSG_RESULT(not specified: still searching...)
+-  AC_CHECK_HEADER(readline.h, [found=yes])
+-fi
+-if test "$found" = "no"; then
+-  for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
+-    AC_CHECK_FILE($dir/include/readline.h, found=yes)
+-    if test "$found" = "yes"; then
+-      TARGET_READLINE_INC="-I$dir/include"
+-      break
+-    fi
+-    AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
+-    if test "$found" = "yes"; then
+-      TARGET_READLINE_INC="-I$dir/include/readline"
+-      break
+-    fi
+-  done
+-fi
+-if test "$found" = "yes"; then
+-  if test "$TARGET_READLINE_LIBS" = ""; then
+-    TARGET_HAVE_READLINE=0
+-  else
+-    TARGET_HAVE_READLINE=1
+-  fi
+-else
+-  TARGET_HAVE_READLINE=0
+-fi
++TARGET_READLINE_INC=""
++TARGET_HAVE_READLINE=1
+ AC_SUBST(TARGET_READLINE_INC)
+ AC_SUBST(TARGET_HAVE_READLINE)
diff --git a/packages/sqlite/sqlite3-3.2.2/ldflags.patch b/packages/sqlite/sqlite3-3.2.2/ldflags.patch
new file mode 100644 (file)
index 0000000..cdc1c51
--- /dev/null
@@ -0,0 +1,77 @@
+Index: sqlite-3.2.1/Makefile.in
+===================================================================
+--- sqlite-3.2.1.orig/Makefile.in      2005-04-25 23:12:10.000000000 +0200
++++ sqlite-3.2.1/Makefile.in   2005-04-25 23:17:39.000000000 +0200
+@@ -31,6 +31,10 @@
+ #
+ TCC = @TARGET_CC@ @TARGET_CFLAGS@ -I. -I${TOP}/src
++# OE overrides
++#
++TARGET_LFLAGS = @TARGET_LFLAGS@
++
+ # Define -DNDEBUG to compile without debugging (i.e., for production usage)
+ # Omitting the define will cause extra debugging code to be inserted and
+ # includes extra comments when "EXPLAIN stmt" is used.
+@@ -228,17 +232,17 @@
+           | awk '{print $$5,$$6}' >last_change
+ libsqlite3.la:        $(LIBOBJ)
+-      $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(LIBPTHREAD) \
++      $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(TARGET_LFLAGS) $(LIBPTHREAD) \
+               ${ALLOWRELEASE} -rpath $(libdir) -version-info "8:6:8"
+ libtclsqlite3.la:     tclsqlite.lo libsqlite3.la
+       $(LTLINK) -o libtclsqlite3.la tclsqlite.lo \
+-              $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(LIBPTHREAD) \
++              $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(TARGET_LFLAGS) $(LIBPTHREAD) \
+                 -rpath $(libdir)/sqlite \
+               -version-info "8:6:8"
+ sqlite3$(TEXE):       $(TOP)/src/shell.c libsqlite3.la sqlite3.h
+-      $(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \
++      $(LTLINK) $(TARGET_LFLAGS) $(READLINE_FLAGS) $(LIBPTHREAD) \
+               -o sqlite3 $(TOP)/src/shell.c libsqlite3.la $(LIBREADLINE)
+ # This target creates a directory named "tsrc" and fills it with
+@@ -413,19 +417,19 @@
+ tclsqlite3:   tclsqlite-shell.lo libsqlite3.la
+       $(LTLINK) -o tclsqlite3 tclsqlite-shell.lo \
+-               libsqlite3.la $(LIBTCL)
++               libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
+ testfixture$(TEXE):   $(TOP)/src/tclsqlite.c libtclsqlite3.la libsqlite3.la $(TESTSRC)
+       $(LTLINK) -DTCLSH=1 -DSQLITE_TEST=1\
+                 $(THREADSAFE) $(TEMP_STORE)\
+                 -o testfixture $(TESTSRC) $(TOP)/src/tclsqlite.c \
+-              libtclsqlite3.la $(LIBTCL)
++              libtclsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
+ crashtest$(TEXE):     $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC) $(TOP)/src/os_test.c
+       $(LTLINK) -DOS_TEST=1 -DTCLSH=1 -DSQLITE_TEST=1 \
+               -o crashtest \
+               $(TESTSRC) $(TOP)/src/os_test.c $(TOP)/src/tclsqlite.c \
+-              libsqlite3.la $(LIBTCL) $(THREADLIB)
++              libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL) $(THREADLIB)
+Index: sqlite-3.2.1/configure.ac
+===================================================================
+--- sqlite-3.2.1.orig/configure.ac     2005-04-25 23:12:10.000000000 +0200
++++ sqlite-3.2.1/configure.ac  2005-04-25 23:12:46.000000000 +0200
+@@ -238,6 +238,13 @@
+   TARGET_LINK=$config_TARGET_LINK
+ fi
+ AC_MSG_RESULT($TARGET_LINK)
++AC_MSG_CHECKING([switches on the target linker])
++if test "$config_TARGET_LFLAGS" != ""; then
++  TARGET_LFLAGS=$config_TARGET_LFLAGS
++else
++  TARGET_LFLAGS=$BUILD_LFLAGS
++fi
++AC_MSG_RESULT($TARGET_LFLAGS)
+ AC_MSG_CHECKING([switches on the target compiler])
+ if test "$config_TARGET_TFLAGS" != ""; then
+   TARGET_TFLAGS=$config_TARGET_TFLAGS
diff --git a/packages/sqlite/sqlite3-3.2.2/libtool.patch b/packages/sqlite/sqlite3-3.2.2/libtool.patch
new file mode 100644 (file)
index 0000000..ccf9993
--- /dev/null
@@ -0,0 +1,25 @@
+Index: sqlite-3.2.1/Makefile.in
+===================================================================
+--- sqlite-3.2.1.orig/Makefile.in      2005-03-23 17:09:39.000000000 +0100
++++ sqlite-3.2.1/Makefile.in   2005-04-25 23:11:20.000000000 +0200
+@@ -15,7 +15,10 @@
+ # The toplevel directory of the source tree.  This is the directory
+ # that contains this "Makefile.in" and the "configure.in" script.
+ #
+-TOP = @srcdir@
++TOP = $(srcdir)
++srcdir = @srcdir@
++top_srcdir = @top_srcdir@
++top_builddir = .
+ # C Compiler and options for use in building executables that
+ # will run on the platform that is doing the build.
+@@ -96,7 +99,7 @@
+ exec_prefix = @exec_prefix@
+ libdir = @libdir@
+ INSTALL = @INSTALL@
+-LIBTOOL = ./libtool
++LIBTOOL = @LIBTOOL@
+ ALLOWRELEASE = @ALLOWRELEASE@
+ # libtool compile/link/install
diff --git a/packages/sqlite/sqlite3_3.2.1.bb b/packages/sqlite/sqlite3_3.2.1.bb
deleted file mode 100644 (file)
index a133f83..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-DESCRIPTION = "An Embeddable SQL Database Engine"
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "readline ncurses"
-LICENSE = "PD"
-
-SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
-          file://cross-compile.patch;patch=1 \
-          file://libtool.patch;patch=1       \
-          file://ldflags.patch;patch=1"
-S = "${WORKDIR}/sqlite-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-tcl --enable-shared \
-               --enable-threadsafe"
-export config_BUILD_CC = "${BUILD_CC}"
-export config_BUILD_CFLAGS = "${BUILD_CFLAGS}"
-export config_BUILD_LIBS = "${BUILD_LDFLAGS}"
-export config_TARGET_CC = "${CC}"
-export config_TARGET_LINK = "${CCLD}"
-export config_TARGET_CFLAGS = "${CFLAGS}"
-export config_TARGET_LFLAGS = "${LDFLAGS}"
-
-do_compile_prepend() {
-       oe_runmake sqlite3.h
-       install -m 0644 sqlite3.h ${STAGING_INCDIR}
-}
-
-do_stage() {
-       oe_libinstall -so libsqlite3 ${STAGING_LIBDIR}
-}
-
-#do_install() {
-#      oe_runmake install DESTDIR=${D} prefix=${prefix} exec_prefix=${exec_prefix}
-#}
-
-PACKAGES = "libsqlite libsqlite-dev libsqlite-doc sqlite3"
-FILES_sqlite3 = "${bindir}/*"
-FILES_libsqlite = "${libdir}/*.so.*"
-FILES_libsqlite-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so \
-                      ${libdir}/pkgconfig ${includedir}"
-FILES_libsqlite-doc = "${docdir} ${mandir} ${infodir}"
-AUTO_LIBNAME_PKGS = "libsqlite"
diff --git a/packages/sqlite/sqlite3_3.2.2.bb b/packages/sqlite/sqlite3_3.2.2.bb
new file mode 100644 (file)
index 0000000..a133f83
--- /dev/null
@@ -0,0 +1,44 @@
+DESCRIPTION = "An Embeddable SQL Database Engine"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "readline ncurses"
+LICENSE = "PD"
+
+SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
+          file://cross-compile.patch;patch=1 \
+          file://libtool.patch;patch=1       \
+          file://ldflags.patch;patch=1"
+S = "${WORKDIR}/sqlite-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-tcl --enable-shared \
+               --enable-threadsafe"
+export config_BUILD_CC = "${BUILD_CC}"
+export config_BUILD_CFLAGS = "${BUILD_CFLAGS}"
+export config_BUILD_LIBS = "${BUILD_LDFLAGS}"
+export config_TARGET_CC = "${CC}"
+export config_TARGET_LINK = "${CCLD}"
+export config_TARGET_CFLAGS = "${CFLAGS}"
+export config_TARGET_LFLAGS = "${LDFLAGS}"
+
+do_compile_prepend() {
+       oe_runmake sqlite3.h
+       install -m 0644 sqlite3.h ${STAGING_INCDIR}
+}
+
+do_stage() {
+       oe_libinstall -so libsqlite3 ${STAGING_LIBDIR}
+}
+
+#do_install() {
+#      oe_runmake install DESTDIR=${D} prefix=${prefix} exec_prefix=${exec_prefix}
+#}
+
+PACKAGES = "libsqlite libsqlite-dev libsqlite-doc sqlite3"
+FILES_sqlite3 = "${bindir}/*"
+FILES_libsqlite = "${libdir}/*.so.*"
+FILES_libsqlite-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so \
+                      ${libdir}/pkgconfig ${includedir}"
+FILES_libsqlite-doc = "${docdir} ${mandir} ${infodir}"
+AUTO_LIBNAME_PKGS = "libsqlite"