alsa-lib_1.0.20: adjust for opendreambox
authorAndreas Oberritter <obi@opendreambox.org>
Tue, 14 Jul 2009 12:48:06 +0000 (14:48 +0200)
committerAndreas Oberritter <obi@opendreambox.org>
Tue, 14 Jul 2009 12:48:06 +0000 (14:48 +0200)
recipes/alsa/alsa-lib_1.0.20.bb

index eff114d..4971605 100644 (file)
@@ -2,6 +2,7 @@ DESCRIPTION = "Alsa sound library"
 HOMEPAGE = "http://www.alsa-project.org"
 SECTION = "libs/multimedia"
 LICENSE = "LGPL"
+PR = "r1"
 
 # configure.in sets -D__arm__ on the command line for any arm system
 # (not just those with the ARM instruction set), this should be removed,
@@ -13,6 +14,7 @@ SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
            file://fix-tstamp-declaration.patch;patch=1 \
           file://fix_libmath.patch;patch=1 \
          "
+SRC_URI_append_opendreambox = " file://asound.conf"
 
 inherit autotools pkgconfig
 
@@ -32,11 +34,17 @@ do_stage () {
        autotools_stage_all
 }
 
+do_install_append_opendreambox() {
+       install -d ${D}${sysconfdir}
+       install -m 0644 ${WORKDIR}/asound.conf ${D}${sysconfdir}/asound.conf
+}
+
 PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
 FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
 FILES_libasound = "${libdir}/libasound.so.*"
 FILES_alsa-server = "${bindir}/*"
 FILES_alsa-conf = "${datadir}/alsa/"
+FILES_alsa-conf_opendreambox = "${datadir}/alsa/ ${sysconfdir}/asound.conf"
 FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
 FILES_alsa-conf-base = "\
 ${datadir}/alsa/alsa.conf \