cups: add 1.2.7, a recipe with less hacks as 1.1.13
authorKoen Kooi <koen@openembedded.org>
Tue, 5 Dec 2006 18:30:54 +0000 (18:30 +0000)
committerKoen Kooi <koen@openembedded.org>
Tue, 5 Dec 2006 18:30:54 +0000 (18:30 +0000)
packages/cups/cups_1.2.7.bb [new file with mode: 0644]

diff --git a/packages/cups/cups_1.2.7.bb b/packages/cups/cups_1.2.7.bb
new file mode 100644 (file)
index 0000000..e49a446
--- /dev/null
@@ -0,0 +1,64 @@
+DESCRIPTION = "An Internet printing system for Unix."
+SECTION = "console/utils"
+LICENSE = "GPL LGPL"
+DEPENDS = "gnutls jpeg dbus dbus-glib libpng zlib install-native fakeroot-native"
+PR = "r0"
+
+SRC_URI = "ftp://ftp3.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
+         "
+
+inherit autotools binconfig
+
+LDFLAGS += " -L${STAGING_LIBDIR} "
+
+EXTRA_OECONF = " \
+                --enable-gnutls \
+               --enable-dbus \
+               --enable-browsing \
+                --disable-openssl \
+               --disable-tiff \
+               "
+
+
+do_configure() {
+       gnu-configize
+       libtoolize --force
+       oe_runconf
+}      
+
+do_compile () {
+       sed -i s:STRIP:NOSTRIP: Makedefs
+       sed -i s:serial:: backend/Makefile
+
+       echo "all:"    >  man/Makefile
+       echo "install:" >> man/Makefile
+
+       oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
+                  "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
+                  "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
+                  "LIBZ=-lz -L${STAGING_LIBDIR}" \
+                  "-I."
+}
+
+fakeroot do_install () {
+       oe_runmake "DSTROOT=${D}" install
+}
+
+do_stage () {
+       install -d ${STAGING_INCDIR}/cups
+       install ${S}/cups/*.h ${STAGING_INCDIR}/cups/
+       install ${S}/filter/*.h ${STAGING_INCDIR}/cups/
+       oe_libinstall -C cups -so libcups ${STAGING_LIBDIR}
+       oe_libinstall -C filter -so libcupsimage ${STAGING_LIBDIR}
+}
+
+#package the html for the webgui inside the main packages (~1MB uncompressed)
+FILES_${PN} += "${datadir}/doc/cups/images \
+               ${datadir}/doc/cups/*html \
+               ${datadir}/doc/cups/*.css \
+                ${datadir}/icons/ \
+              "
+
+
+
+