modphp: fixed build errors
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Sat, 21 Feb 2009 10:04:52 +0000 (11:04 +0100)
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Sat, 21 Feb 2009 10:04:52 +0000 (11:04 +0100)
packages/modphp/modphp5.inc
packages/modphp/modphp_5.1.6.bb

index e8701b0..3aaaf03 100644 (file)
@@ -13,7 +13,8 @@ inherit autotools
 FILES_${PN} = "${libdir}/apache2 /etc"
 FILES_${PN}-dbg += "${libdir}/apache2/modules/.debug"
 
-CFLAGS += " -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+CFLAGS += " -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_INCDIR_NATIVE}/apache2"
+
 EXTRA_OECONF = "--with-apxs2=${STAGING_BINDIR_NATIVE}/apxs \
                 --without-mysql \
                --enable-force-cgi-redirect \
@@ -29,7 +30,7 @@ EXTRA_OECONF = "--with-apxs2=${STAGING_BINDIR_NATIVE}/apxs \
                --disable-simplexml \
                --disable-libxml \
                --disable-dom \
-                --with-zlib --with-zlib-dir=${STAGING_DIR_NATIVE}${layout_exec_prefix} \
+                --with-zlib --with-zlib-dir=${STAGING_DIR}${layout_exec_prefix}/.. \
                 --with-config-file-path=/etc/php/apache2-php5"
 
 #              --with-libxml-dir=${STAGING_DIR_NATIVE}${layout_exec_prefix} \
index 7c421c1..70a578c 100644 (file)
@@ -1,2 +1,2 @@
 include modphp5.inc
-PR ='r2'
+PR ='r3'