fbida: fix some stuff
authorHenning Heinold <heinold@inf.fu-berlin.de>
Sun, 12 Oct 2008 17:47:33 +0000 (17:47 +0000)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Sun, 12 Oct 2008 17:47:33 +0000 (17:47 +0000)
* add sys_siglist.patch, sys_siglist[x] should not be used anymore,
  strsignal() is the better way
* package is not based on autotools
* add runtime dependency ttf-dejavu-sans-mono as suggested in
  the bugreport
* add libiconv as depedency to make uClibc builds happy
* remove build depenency on ttf-dejavu
* bump PR

packages/fbida/fbida_2.07.bb
packages/fbida/files/sys_siglist.patch [new file with mode: 0644]

index 9360600..f163bb5 100644 (file)
@@ -8,14 +8,16 @@ DESCRIPTION = "frame buffer image and doc viewer tools"
 AUTHOR = "Gerd Knorr"
 LICENSE = "GPL2"
 SECTION = "utils"
-DEPENDS = "jpeg fontconfig freetype libexif ttf-dejavu"
+PR = "r1"
+
+DEPENDS = "libiconv jpeg fontconfig freetype libexif"
+RDEPENDS = "ttf-dejavu-sans-mono"
 
 SRC_URI = "http://dl.bytesex.org/releases/fbida/fbida-${PV}.tar.gz \
           file://exiftran.c.patch;patch=1 \
           file://fbi.c.patch;patch=1 \
-          file://GNUmakefile.patch;patch=1"
-
-inherit autotools
+          file://GNUmakefile.patch;patch=1 \
+          file://sys_siglist.patch;patch=1 \
+         "
 
-#CFLAGS_append = " ${LDFLAGS}"
 EXTRA_OECONF = "--disable-magick --without-x"
diff --git a/packages/fbida/files/sys_siglist.patch b/packages/fbida/files/sys_siglist.patch
new file mode 100644 (file)
index 0000000..ae816d4
--- /dev/null
@@ -0,0 +1,12 @@
+Index: fbida-2.07/fbtools.c
+===================================================================
+--- fbida-2.07.orig/fbtools.c  2008-10-11 12:49:38.676243745 +0200
++++ fbida-2.07/fbtools.c       2008-10-11 12:50:08.286262765 +0200
+@@ -519,6 +519,6 @@
+     /* cleanup */
+     fb_cleanup();
+-    fprintf(stderr,"Oops: %s\n",sys_siglist[termsig]);
++    fprintf(stderr,"Oops: %s\n",strsignal(termsig));
+     exit(42);
+ }