python-pygobject[-native] 2.12.3: update to 2.14.2, adjust patches and -native package
authorMichael Lauer <mickey@vanille-media.de>
Sun, 22 Jun 2008 11:50:28 +0000 (11:50 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Sun, 22 Jun 2008 11:50:28 +0000 (11:50 +0000)
packages/python/python-pygobject-native_2.12.3.bb [deleted file]
packages/python/python-pygobject-native_2.14.2.bb [new file with mode: 0644]
packages/python/python-pygobject/generate-constants.patch [new file with mode: 0644]
packages/python/python-pygobject/python-path.patch
packages/python/python-pygobject_2.12.3.bb [deleted file]
packages/python/python-pygobject_2.14.2.bb [new file with mode: 0644]

diff --git a/packages/python/python-pygobject-native_2.12.3.bb b/packages/python/python-pygobject-native_2.12.3.bb
deleted file mode 100644 (file)
index 3b8c204..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-require python-pygobject_${PV}.bb
-
-DEPENDS = "python-native glib-2.0-native"
-
-MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
-SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 "
-
-inherit native
diff --git a/packages/python/python-pygobject-native_2.14.2.bb b/packages/python/python-pygobject-native_2.14.2.bb
new file mode 100644 (file)
index 0000000..532bcb6
--- /dev/null
@@ -0,0 +1,10 @@
+require python-pygobject_${PV}.bb
+
+DEPENDS = "python-native glib-2.0-native"
+
+inherit native
+
+do_stage_append() {
+       install -d ${STAGING_BINDIR}
+       install -m 0755 gobject/generate-constants ${STAGING_BINDIR}/gobject-generate-constants
+}
diff --git a/packages/python/python-pygobject/generate-constants.patch b/packages/python/python-pygobject/generate-constants.patch
new file mode 100644 (file)
index 0000000..57a9380
--- /dev/null
@@ -0,0 +1,18 @@
+Index: pygobject-2.14.2/gobject/Makefile.am
+===================================================================
+--- pygobject-2.14.2.orig/gobject/Makefile.am
++++ pygobject-2.14.2/gobject/Makefile.am
+@@ -21,11 +21,11 @@ if PLATFORM_WIN32
+ common_ldflags += -no-undefined
+ endif
+-constants.py: generate-constants$(EXEEXT) constants.py.in
++constants.py: constants.py.in
+       rm -f constants.py
+       cp $(srcdir)/constants.py.in constants.py
+       chmod 644 constants.py
+-      $(top_builddir)/gobject/generate-constants$(EXEEXT) >> constants.py
++      gobject-generate-constants$(EXEEXT) >> constants.py
+       chmod 444 constants.py
+ generate_constants_CFLAGS = $(GLIB_CFLAGS)
index 2ab7bdc..d790770 100644 (file)
@@ -1,23 +1,46 @@
-Index: pygobject-2.12.3/m4/python.m4
+Index: pygobject-2.14.2/m4/python.m4
 ===================================================================
---- pygobject-2.12.3.orig/m4/python.m4 2007-03-02 15:00:20.945635455 +0100
-+++ pygobject-2.12.3/m4/python.m4      2007-03-02 15:00:43.532189734 +0100
-@@ -43,12 +43,18 @@
+--- pygobject-2.14.2.orig/m4/python.m4
++++ pygobject-2.14.2/m4/python.m4
+@@ -43,6 +43,11 @@ AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
  [AC_REQUIRE([AM_PATH_PYTHON])
  AC_MSG_CHECKING(for headers required to compile python extensions)
  dnl deduce PYTHON_INCLUDES
 +AC_ARG_WITH(python-includes,
-+      [  --with-python-includes=DIR  path to Python includes], py_exec_prefix=$withval)
++       [  --with-python-includes=DIR  path to Python includes], py_exec_prefix=$withval)
 +if test x$py_exec_prefix != x; then
 +PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
 +else
  py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
  py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
- PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
- if test "$py_prefix" != "$py_exec_prefix"; then
+ if test -x "$PYTHON-config"; then
+@@ -53,6 +58,7 @@ if test "$py_prefix" != "$py_exec_prefix
    PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
  fi
+ fi
 +fi
  AC_SUBST(PYTHON_INCLUDES)
  dnl check if the headers exist:
  save_CPPFLAGS="$CPPFLAGS"
+Index: pygobject-2.14.2/configure.ac
+===================================================================
+--- pygobject-2.14.2.orig/configure.ac
++++ pygobject-2.14.2/configure.ac
+@@ -71,9 +71,6 @@ AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(c
+ AC_MSG_CHECKING([for PySignal_SetWakeupFd in Python.h])
+ py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+-PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+-old_CPPFLAGS=$CPPFLAGS
+-CPPFLAGS="-Wall -Werror $PYTHON_INCLUDES"
+ AC_TRY_COMPILE([#include <Python.h>],
+   [PySignal_SetWakeupFd(0);],
+   setwakeupfd_ok=yes,
+@@ -83,7 +80,6 @@ if test "x$setwakeupfd_ok" != xno; then
+   AC_DEFINE(HAVE_PYSIGNAL_SETWAKEUPFD, 1,
+                 [Define to 1 if PySignal_SetWakeupFd is available])
+ fi
+-CPPFLAGS=$old_CPPFLAGS
+ PLATFORM=`$PYTHON -c "from distutils import util; print util.get_platform()"`
+ AC_SUBST(PLATFORM)
diff --git a/packages/python/python-pygobject_2.12.3.bb b/packages/python/python-pygobject_2.12.3.bb
deleted file mode 100644 (file)
index c7781c3..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "Python GObject bindings"
-SECTION = "devel/python"
-LICENSE = "LGPL"
-DEPENDS = "python-pygobject-native"
-PR = "r3"
-
-MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
-SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
-           file://python-path.patch;patch=1"
-S = "${WORKDIR}/pygobject-${PV}"
-
-inherit autotools distutils-base pkgconfig
-
-EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
-
-do_stage() {
-       autotools_stage_all
-       install -d ${STAGING_LIBDIR}/../share/pygobject/
-       cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
-       install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
-       cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
-}
-
-FILES_${PN} = "${libdir}/python*"
-FILES_${PN}-dev += "${datadir}/pygobject/xsl"
diff --git a/packages/python/python-pygobject_2.14.2.bb b/packages/python/python-pygobject_2.14.2.bb
new file mode 100644 (file)
index 0000000..81a77ef
--- /dev/null
@@ -0,0 +1,31 @@
+DESCRIPTION = "Python GObject bindings"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+DEPENDS = "python-pygobject-native"
+PR = "r0"
+
+MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+SRC_URI = "\
+  ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
+  file://python-path.patch;patch=1 \
+  file://generate-constants.patch;patch=1 \
+"
+S = "${WORKDIR}/pygobject-${PV}"
+
+FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
+
+inherit autotools distutils-base pkgconfig
+
+EXTRA_OECONF += '--with-python-includes="${STAGING_INCDIR}/.."'
+
+do_stage() {
+       autotools_stage_all
+       install -d ${STAGING_LIBDIR}/../share/pygobject/
+       cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
+       install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+       cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+}
+
+FILES_${PN} = "${libdir}/python*"
+FILES_${PN}-dev += "${datadir}/pygobject/xsl"