add task-x11 and task-x11-illume
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Wed, 15 Oct 2008 19:33:01 +0000 (21:33 +0200)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Thu, 16 Oct 2008 12:26:17 +0000 (14:26 +0200)
packages/tasks/task-x11-illume.bb [new file with mode: 0644]
packages/tasks/task-x11.bb [new file with mode: 0644]

diff --git a/packages/tasks/task-x11-illume.bb b/packages/tasks/task-x11-illume.bb
new file mode 100644 (file)
index 0000000..a477c6e
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "The Illume Windowing Environment -- install this task to get the Enlightenment Window Manager + the Illume environment."
+SECTION = "x11/wm"
+LICENSE = "MIT"
+PV = "1.0"
+PR = "r0"
+
+# WORK IN PROGRESS
+
+inherit task
+
+# Default illume theme
+ILLUME_THEME ?= "illume-theme-illume"
+
+RDEPENDS_${PN} = "\
+  task-x11-server \
+  task-x11-utils \
+#  xserver-kdrive-splash-illume \
+  \
+  e-wm \
+  illume \
+  illume-config-illume \
+  illume-dicts-english-us \
+  illume-keyboards-default \
+  illume-keyboards-numbers \
+  illume-keyboards-terminal \
+  ${ILLUME_THEME} \
+"
diff --git a/packages/tasks/task-x11.bb b/packages/tasks/task-x11.bb
new file mode 100644 (file)
index 0000000..ad5ca3a
--- /dev/null
@@ -0,0 +1,36 @@
+DESCRIPTION = "The X Window System -- install this task to get a client/server based display multiplexer."
+SECTION = "x11/server"
+LICENSE = "MIT"
+PV = "1.0"
+PR = "r0"
+
+# WORK IN PROGRESS
+
+inherit task
+
+PACKAGES += "\
+  ${PN}-server \
+  ${PN}-utils \
+"
+
+RRECOMMENDS_${PN} = "\
+  ${PN}-server \
+  ${PN}-utils \
+"
+
+# Some machines don't set a *runtime* provider for X, so default to Xfbdev here
+# virtual/xserver won't work, since the kdrive recipes will build multiple xserver packages
+XSERVER ?= "xserver-kdrive-fbdev"
+
+RDEPENDS_${PN}-server = "\
+  ${XSERVER} \
+"
+
+RDEPENDS_${PN}-utils = "\
+  xserver-kdrive-common \
+  xserver-nodm-init \
+  xauth \
+  xhost \
+  xset \
+  xrandr \
+"