u-boot-omap2430sdp : Add u-boot support for omap2430sdp. Delete when support movies...
authorPhilip Balister <philip@balister.org>
Tue, 14 Aug 2007 21:32:46 +0000 (21:32 +0000)
committerPhilip Balister <philip@balister.org>
Tue, 14 Aug 2007 21:32:46 +0000 (21:32 +0000)
packages/uboot/u-boot-omap2430sdp-1.1.4/.mtn2git_empty [new file with mode: 0644]
packages/uboot/u-boot-omap2430sdp-1.1.4/u-boot-makefile-3.81.patch [new file with mode: 0644]
packages/uboot/u-boot-omap2430sdp_1.1.4.bb [new file with mode: 0644]

diff --git a/packages/uboot/u-boot-omap2430sdp-1.1.4/.mtn2git_empty b/packages/uboot/u-boot-omap2430sdp-1.1.4/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/uboot/u-boot-omap2430sdp-1.1.4/u-boot-makefile-3.81.patch b/packages/uboot/u-boot-omap2430sdp-1.1.4/u-boot-makefile-3.81.patch
new file mode 100644 (file)
index 0000000..f45a1d3
--- /dev/null
@@ -0,0 +1,11 @@
+--- u-boot/examples/Makefile.orig      2007-08-13 13:09:59.000000000 -0700
++++ u-boot/examples/Makefile   2007-08-13 13:11:34.000000000 -0700
+@@ -128,6 +128,8 @@ all:       .depend $(OBJS) $(LIB) $(SREC) $(BI
+ $(LIB): .depend $(LIBOBJS)
+       $(AR) crv $@ $(LIBOBJS)
++hello_world.srec: hello_world
++
+ %:    %.o $(LIB)
+       $(LD) -g $(EX_LDFLAGS) -Ttext $(LOAD_ADDR) \
+               -o $@ -e $(<:.o=) $< $(LIB) \
diff --git a/packages/uboot/u-boot-omap2430sdp_1.1.4.bb b/packages/uboot/u-boot-omap2430sdp_1.1.4.bb
new file mode 100644 (file)
index 0000000..4dcc989
--- /dev/null
@@ -0,0 +1,13 @@
+require u-boot.inc
+PR="r1"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://linux.omap.com/pub/bootloader/2430sdp/source/u-boot-SEP1106.tar.gz \
+           file://u-boot-makefile-3.81.patch;patch=1 \
+          "
+
+S = "${WORKDIR}/u-boot"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#inherit base