add task-fonts-truetype
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Wed, 15 Oct 2008 18:29:49 +0000 (20:29 +0200)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Wed, 15 Oct 2008 18:32:55 +0000 (20:32 +0200)
packages/tasks/task-fonts-truetype.bb [new file with mode: 0644]

diff --git a/packages/tasks/task-fonts-truetype.bb b/packages/tasks/task-fonts-truetype.bb
new file mode 100644 (file)
index 0000000..cd80003
--- /dev/null
@@ -0,0 +1,39 @@
+DESCRIPTION = "Install one of these tasks to get support for truetype fonts."
+SECTION = "fonts"
+LICENSE = "MIT"
+PV = "1.0"
+PR = "r0"
+
+inherit task
+
+PACKAGES += "\
+  ${PN}-core \
+  ${PN}-chinese \
+  ${PN}-japanese \
+"
+
+RRECOMMENDS_task-fonts-truetype = "\
+  ${PN}-core \
+  ${PN}-chinese \
+  ${PN}-japanese \
+"
+
+RDEPENDS_task-fonts-truetype-core = "\
+  fontconfig-utils \
+  \
+  ttf-dejavu-common \
+  ttf-dejavu-sans \
+#  ttf-dejavu-serif \
+  ttf-dejavu-sans-mono \
+"
+
+RDEPENDS_task-fonts-truetype-chinese = "\
+  ${PN}-core \
+  ttf-arphic-uming \
+"
+
+RDEPENDS_task-fonts-truetype-japanese = "\
+  ${PN}-core \
+  ttf-sazanami-gothic \
+  ttf-sazanami-mincho \
+"