alsa-utils_1.0.18: Check for strlcat and stlcpy functions during configure
authorKhem Raj <raj.khem@gmail.com>
Thu, 12 Feb 2009 08:27:02 +0000 (00:27 -0800)
committerKhem Raj <raj.khem@gmail.com>
Thu, 12 Feb 2009 08:27:02 +0000 (00:27 -0800)
packages/alsa/alsa-utils_1.0.18.bb
packages/alsa/files/alsa-utils-autoconf-strl-funcs.patch [new file with mode: 0644]

index 4de9180..2931545 100644 (file)
@@ -8,7 +8,7 @@ PR = "r1"
 SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \
            file://alsa-utils-automake.patch;patch=1 \
           file://alsa-utils-remove-xmlto.patch;patch=1 \
-          file://alsa-utils-strl-funcs-non-static.patch;patch=1 \
+          file://alsa-utils-autoconf-strl-funcs.patch;patch=1 \
          "
 
 inherit autotools
diff --git a/packages/alsa/files/alsa-utils-autoconf-strl-funcs.patch b/packages/alsa/files/alsa-utils-autoconf-strl-funcs.patch
new file mode 100644 (file)
index 0000000..0c8404d
--- /dev/null
@@ -0,0 +1,43 @@
+Index: alsa-utils-1.0.18/alsactl/init_sysdeps.c
+===================================================================
+--- alsa-utils-1.0.18.orig/alsactl/init_sysdeps.c      2008-10-29 05:42:11.000000000 -0700
++++ alsa-utils-1.0.18/alsactl/init_sysdeps.c   2009-02-10 23:17:47.000000000 -0800
+@@ -17,7 +17,7 @@
+  *
+  */
+-#ifdef __GLIBC__
++#if !HAVE_STRLCPY
+ static size_t strlcpy(char *dst, const char *src, size_t size)
+ {
+       size_t bytes = 0;
+@@ -36,7 +36,10 @@
+               *q = '\0';
+       return bytes;
+ }
++#endif /* !HAVE_STRLCPY */
++
++#if !HAVE_STRLCAT
+ static size_t strlcat(char *dst, const char *src, size_t size)
+ {
+       size_t bytes = 0;
+@@ -60,4 +63,4 @@
+       *q = '\0';
+       return bytes;
+ }
+-#endif /* __GLIBC__ */
++#endif /* !HAVE_STRLCAT */
+Index: alsa-utils-1.0.18/configure.in
+===================================================================
+--- alsa-utils-1.0.18.orig/configure.in        2008-10-29 05:48:01.000000000 -0700
++++ alsa-utils-1.0.18/configure.in     2009-02-10 23:02:07.000000000 -0800
+@@ -6,7 +6,7 @@
+ AM_GNU_GETTEXT([external])
+ AM_GNU_GETTEXT_VERSION([0.15])
+-
++AC_CHECK_FUNCS(strlcat strlcpy)
+ dnl Checks for programs.
+ dnl try to gues cross-compiler if not set