picodlp-control: add options to control individual leds and overall led current
authorRobert Nelson <robert.nelson@digikey.com>
Fri, 20 Feb 2009 16:02:08 +0000 (17:02 +0100)
committerKoen Kooi <koen@openembedded.org>
Fri, 20 Feb 2009 16:02:56 +0000 (17:02 +0100)
Signed-off-by: Koen Kooi <koen@openembedded.org>
packages/i2c-tools/picodlp-control/picodlp-control
packages/i2c-tools/picodlp-control_0.1.bb

index dd7d9bf..3c3cd5a 100755 (executable)
@@ -43,8 +43,45 @@ case ${PICO_OPTION} in
                                ${I2C_APP} ${PICO_ADDRESS} wb4 0x26 ${WORD_OFF}
                        fi;;
 
+"rled")
+                       if [ $2 -gt 0 ] ; then
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x11 ${WORD_ON}
+                       else
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x11 ${WORD_OFF}
+                       fi;;
+
+"gled")
+                       if [ $2 -gt 0 ] ; then
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x12 ${WORD_ON}
+                       else
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x12 ${WORD_OFF}
+                       fi;;
+
+"bled")
+                       if [ $2 -gt 0 ] ; then
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x13 ${WORD_ON}
+                       else
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x13 ${WORD_OFF}
+                       fi;;    
+
+"itp")
+                       if [ $2 -gt 0 ] ; then
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x0B ${WORD_OFF}
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x04 ${WORD_ON}
+                               #Parallel RGB Setting
+                       else
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x0B $3
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x04 ${WORD_OFF}
+                               #Test Pattern
+                       fi;;    
+"ledc")
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x0E $4
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x0F $5
+                               ${I2C_APP} ${PICO_ADDRESS} wb4 0x10 $6
+                       ;;
+
 *)
-                       echo "Usage: $0 vflip|hflip|temporal-enhance 0/1";;
+                       echo "Usage: $0 vflip|hflip|temporal-enhance|rled|gled|bled|itp|ledc 0/1 0x";;
 esac
 
 
index 79a896b..5fb5630 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "Small application to control the pico DLP over I2C"
 LICENSE = "GPLv3"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "file://*.c file://*.h file://${PN}"