Merge oe-devel@oe-devel.bkbits.net:openembedded
authorChris Larson <clarson@kergoth.com>
Thu, 3 Feb 2005 18:27:08 +0000 (18:27 +0000)
committerChris Larson <clarson@kergoth.com>
Thu, 3 Feb 2005 18:27:08 +0000 (18:27 +0000)
into handhelds.org:/home/kergoth/code/openembedded

2005/02/03 13:26:41-05:00 handhelds.org!kergoth
Apply patch to add the armeb target arch to openssl Configure, consolodate openssl metadata into a .inc, and fixup the openssl builds to define L_ENDIAN or B_ENDIAN appropriately.

BKrev: 42026cfcbWNDqq37LnoEZ-ReFeLBkA

packages/openssl/openssl-0.9.7b/armeb.patch [new file with mode: 0644]
packages/openssl/openssl-0.9.7d/armeb.patch [new file with mode: 0644]
packages/openssl/openssl-0.9.7e/armeb.patch [new file with mode: 0644]
packages/openssl/openssl.inc [new file with mode: 0644]
packages/openssl/openssl_0.9.7b.bb
packages/openssl/openssl_0.9.7c.bb [deleted file]
packages/openssl/openssl_0.9.7d.bb
packages/openssl/openssl_0.9.7e.bb

diff --git a/packages/openssl/openssl-0.9.7b/armeb.patch b/packages/openssl/openssl-0.9.7b/armeb.patch
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/openssl/openssl-0.9.7d/armeb.patch b/packages/openssl/openssl-0.9.7d/armeb.patch
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/openssl/openssl-0.9.7e/armeb.patch b/packages/openssl/openssl-0.9.7e/armeb.patch
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/openssl/openssl.inc b/packages/openssl/openssl.inc
new file mode 100644 (file)
index 0000000..e69de29
index 684bd87..e502020 100644 (file)
@@ -1,43 +1,6 @@
-SECTION = "libs"
-DESCRIPTION = "Secure Socket Layer (SSL) binary and related cryptographic tools."
-LICENSE = "openssl SSLeay"
-SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
-          file://debian.patch;patch=1"
-S = "${WORKDIR}/openssl-${PV}"
+include openssl.inc
 
-AR_append = " r"
-export CFLAG = "-fPIC -DTHREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DL_ENDIAN -DTERMIO -Wall ${FULL_OPTIMIZATION}"
-export DIRS = "crypto ssl"
-export EX_LIBS = "-lgcc -ldl -L${STAGING_LIBDIR}"
-export AS = "${CC} -c"
+PR = "r1"
 
-do_compile () {
-       perl util/perlpath.pl ${bindir}
-       ln -sf apps/openssl.pod crypto/crypto.pod ssl/ssl.pod doc/
-       if test "X${TARGET_OS}" = "Xlinux"; then
-               target=${TARGET_OS}-elf
-       else
-               target=${TARGET_OS}
-       fi
-       if ! test "X${BUILD_SYS}" = "X${TARGET_SYS}" -o \
-               "X${TARGET_ARCH}" = "Xi386" -o \
-               "X${TARGET_ARCH}" = "Xi686" -o \
-               "X${TARGET_ARCH}" = "Xi586" -o \
-               "X${TARGET_ARCH}" = "Xi486"; then
-               target="$target-${TARGET_ARCH}"
-       fi
-       perl ./Configure shared --prefix=${prefix} --openssldir=${libdir}/ssl $target
-       oe_runmake -f Makefile.ssl
-       perl ./Configure no-shared --prefix=${prefix} --openssldir=${libdir}/ssl $target
-       oe_runmake -f Makefile.ssl
-}
-
-do_stage () {
-       cp --dereference -R include/openssl ${STAGING_INCDIR}/
-       oe_libinstall -so libcrypto ${STAGING_LIBDIR}
-       oe_libinstall -so libssl ${STAGING_LIBDIR}
-}
-
-do_install () {
-       oe_runmake -f Makefile.ssl INSTALL_PREFIX="${D}" install
-}
+SRC_URI += "file://debian.patch;patch=1 \
+           file://armeb.patch;patch=1"
diff --git a/packages/openssl/openssl_0.9.7c.bb b/packages/openssl/openssl_0.9.7c.bb
deleted file mode 100644 (file)
index de65ff7..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-SECTION = "libs"
-DESCRIPTION = "Secure Socket Layer (SSL) binary and related cryptographic tools."
-LICENSE = "openssl SSLeay"
-SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
-          ${DEBIAN_MIRROR}/main/o/${PN}/${PN}_${PV}-5.diff.gz"
-S = "${WORKDIR}/openssl-${PV}"
-
-AR_append = " r"
-export CFLAG = "-fPIC -DTHREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DL_ENDIAN -DTERMIO -Wall ${FULL_OPTIMIZATION}"
-export DIRS = "crypto ssl"
-export EX_LIBS = "-lgcc -ldl -L${STAGING_LIBDIR}"
-export AS = "${CC} -c"
-
-do_compile () {
-       perl util/perlpath.pl ${bindir}
-       ln -sf apps/openssl.pod crypto/crypto.pod ssl/ssl.pod doc/
-       if test "X${TARGET_OS}" = "Xlinux"; then
-               target=${TARGET_OS}-elf
-       else
-               target=${TARGET_OS}
-       fi
-       if ! test "X${BUILD_SYS}" = "X${TARGET_SYS}" -o \
-               "X${TARGET_ARCH}" = "Xi386" -o \
-               "X${TARGET_ARCH}" = "Xi686" -o \
-               "X${TARGET_ARCH}" = "Xi586" -o \
-               "X${TARGET_ARCH}" = "Xi486"; then
-               target="$target-${TARGET_ARCH}"
-       fi
-       perl ./Configure shared --prefix=${prefix} --openssldir=${libdir}/ssl $target
-       oe_runmake -f Makefile.ssl
-       perl ./Configure no-shared --prefix=${prefix} --openssldir=${libdir}/ssl $target
-       oe_runmake -f Makefile.ssl
-}
-
-do_stage () {
-       cp --dereference -R include/openssl ${STAGING_INCDIR}/
-       oe_libinstall -a -so libcrypto ${STAGING_LIBDIR}
-       oe_libinstall -a -so libssl ${STAGING_LIBDIR}
-}
-
-do_install () {
-       install -d ${D}/${libdir}/pkgconfig
-       oe_runmake -f Makefile.ssl INSTALL_PREFIX="${D}" install
-       chmod u+rx ${D}/${libdir}/pkgconfig
-       chmod 644 ${D}/${libdir}/pkgconfig/openssl.pc
-}
index 88ed064..8882de6 100644 (file)
@@ -1,78 +1,6 @@
-SECTION = "libs"
-DESCRIPTION = "Secure Socket Layer (SSL) binary and related cryptographic tools."
-HOMEPAGE = "http://www.openssl.org/"
-LICENSE = "openssl"
-PR = "r2"
+include openssl.inc
 
-SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
-          file://debian.patch;patch=1"
-S = "${WORKDIR}/openssl-${PV}"
+PR = "r3"
 
-AR_append = " r"
-export CFLAG = "-fPIC -DTHREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DL_ENDIAN -DTERMIO -Wall ${FULL_OPTIMIZATION}"
-
-# -02 does not work on mipsel: ssh hangs when it tries to read /dev/urandom
-export CFLAG_mtx-1 := "${@'${CFLAG}'.replace('-O2', '')}"
-
-export DIRS = "crypto ssl apps"
-export EX_LIBS = "-lgcc -ldl -L${STAGING_LIBDIR}"
-export AS = "${CC} -c"
-
-PACKAGES =+ "libcrypto libssl"
-FILES_libcrypto = "${libdir}/libcrypto.so*"
-FILES_libssl = "${libdir}/libssl.so*"
-
-do_compile () {
-       perl util/perlpath.pl ${bindir}
-       ln -sf apps/openssl.pod crypto/crypto.pod ssl/ssl.pod doc/
-
-       #
-       # NOTE: Yes.  This does suck.  Ugh.
-       #
-       os=${HOST_OS}
-       if [ "x$os" = "xlinux-uclibc" ]; then
-               os=linux
-       fi
-       case $os-${HOST_ARCH} in
-       linux-arm)
-               target=linux-elf-arm
-               ;;
-       linux-i[34]86)
-               target=linux-elf
-               ;;
-       linux-i586)
-               target=linux-pentium
-               ;;
-       linux-i686)
-               target=linux-ppro
-               ;;
-       linux-mipsel)
-               target=linux-mipsel
-               ;;
-        linux-powerpc)
-                target=linux-ppc
-                ;;
-       linux-x86_64)
-               target=linux-x86_64
-               ;;
-       *)
-               die "Unsupported OS-ARCH ${HOST_OS}-${HOST_ARCH}"
-               ;;
-       esac
-       perl ./Configure shared --prefix=${prefix} --openssldir=${libdir}/ssl $target
-       oe_runmake -f Makefile.ssl
-}
-
-do_stage () {
-       cp --dereference -R include/openssl ${STAGING_INCDIR}/
-       oe_libinstall -a -so libcrypto ${STAGING_LIBDIR}
-       oe_libinstall -a -so libssl ${STAGING_LIBDIR}
-}
-
-do_install () {
-       install -m 0755 -d ${D}/${libdir}/pkgconfig
-       oe_runmake -f Makefile.ssl INSTALL_PREFIX="${D}" install
-       chmod 644 ${D}/${libdir}/pkgconfig/openssl.pc
-       oe_libinstall -so libcrypto ${D}/${libdir}
-       oe_libinstall -so libssl ${D}/${libdir}
-}
+SRC_URI += "file://debian.patch;patch=1 \
+           file://armeb.patch;patch=1"
index 8faca57..e502020 100644 (file)
@@ -1,79 +1,6 @@
-SECTION = "libs"
-DESCRIPTION = "Secure Socket Layer (SSL) binary and related cryptographic tools."
-HOMEPAGE = "http://www.openssl.org/"
-LICENSE = "openssl"
+include openssl.inc
 
-SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
-          file://debian.patch;patch=1"
-S = "${WORKDIR}/openssl-${PV}"
+PR = "r1"
 
-AR_append = " r"
-export CFLAG = "-fPIC -DTHREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DL_ENDIAN -DTERMIO -Wall ${FULL_OPTIMIZATION}"
-
-# -02 does not work on mipsel: ssh hangs when it tries to read /dev/urandom
-export CFLAG_mtx-1 := "${@'${CFLAG}'.replace('-O2', '')}"
-
-export DIRS = "crypto ssl apps"
-export EX_LIBS = "-lgcc -ldl -L${STAGING_LIBDIR}"
-export AS = "${CC} -c"
-
-PACKAGES =+ "libcrypto libssl"
-FILES_libcrypto = "${libdir}/libcrypto.so*"
-FILES_libssl = "${libdir}/libssl.so*"
-
-do_compile () {
-       cd util
-       perl perlpath.pl ${bindir}
-       cd ..
-       ln -sf apps/openssl.pod crypto/crypto.pod ssl/ssl.pod doc/
-
-       #
-       # NOTE: Yes.  This does suck.  Ugh.
-       #
-       os=${HOST_OS}
-       if [ "x$os" = "xlinux-uclibc" ]; then
-               os=linux
-       fi
-       case $os-${HOST_ARCH} in
-       linux-arm)
-               target=linux-elf-arm
-               ;;
-       linux-i[34]86)
-               target=linux-elf
-               ;;
-       linux-i586)
-               target=linux-pentium
-               ;;
-       linux-i686)
-               target=linux-ppro
-               ;;
-       linux-mipsel)
-               target=linux-mipsel
-               ;;
-        linux-powerpc)
-                target=linux-ppc
-                ;;
-       linux-x86_64)
-               target=linux-x86_64
-               ;;
-       *)
-               die "Unsupported OS-ARCH ${HOST_OS}-${HOST_ARCH}"
-               ;;
-       esac
-       perl ./Configure shared --prefix=${prefix} --openssldir=${libdir}/ssl $target
-       oe_runmake
-}
-
-do_stage () {
-       cp --dereference -R include/openssl ${STAGING_INCDIR}/
-       oe_libinstall -a -so libcrypto ${STAGING_LIBDIR}
-       oe_libinstall -a -so libssl ${STAGING_LIBDIR}
-}
-
-do_install () {
-       install -m 0755 -d ${D}/${libdir}/pkgconfig
-       oe_runmake INSTALL_PREFIX="${D}" install
-       chmod 644 ${D}/${libdir}/pkgconfig/openssl.pc
-       oe_libinstall -so libcrypto ${D}/${libdir}
-       oe_libinstall -so libssl ${D}/${libdir}
-}
+SRC_URI += "file://debian.patch;patch=1 \
+           file://armeb.patch;patch=1"