enable devfsd on dm7025
authorAndreas Oberritter <obi@opendreambox.org>
Sat, 5 Feb 2011 16:55:46 +0000 (17:55 +0100)
committerAndreas Oberritter <obi@opendreambox.org>
Sun, 6 Feb 2011 23:19:44 +0000 (00:19 +0100)
recipes/busybox/busybox-1.15.3/devfsd.conf [new file with mode: 0644]
recipes/busybox/busybox-1.15.3/opendreambox/defconfig
recipes/busybox/busybox_1.15.3.bb
recipes/initscripts/initscripts-1.0/dm7025/bootup_old
recipes/initscripts/initscripts-opendreambox_1.0.bb

diff --git a/recipes/busybox/busybox-1.15.3/devfsd.conf b/recipes/busybox/busybox-1.15.3/devfsd.conf
new file mode 100644 (file)
index 0000000..46542e8
--- /dev/null
@@ -0,0 +1,17 @@
+# Enable full compatibility mode for old device names.
+REGISTER       .*              MKOLDCOMPAT
+UNREGISTER     .*              RMOLDCOMPAT
+
+# Restoring /dev/log on startup would trigger the minilogd/initlog deadlock
+# (minilogd falsely assuming syslogd has been started).
+REGISTER       ^log$           IGNORE
+CREATE         ^log$           IGNORE
+CHANGE         ^log$           IGNORE
+DELETE         ^log$           IGNORE
+
+# Uncomment this if you want permissions to be saved and restored
+# Do not do this for pseudo-terminal devices
+REGISTER       ^pt[sy]         IGNORE
+CREATE         ^pt[sy]         IGNORE
+CHANGE         ^pt[sy]         IGNORE
+DELETE         ^pt[sy]         IGNORE
index db027c9..35cc4a6 100644 (file)
@@ -582,7 +582,7 @@ CONFIG_FEATURE_CROND_DIR=""
 CONFIG_CRONTAB=y
 # CONFIG_DC is not set
 # CONFIG_FEATURE_DC_LIBM is not set
-# CONFIG_DEVFSD is not set
+CONFIG_DEVFSD=y
 # CONFIG_DEVFSD_MODLOAD is not set
 # CONFIG_DEVFSD_FG_NP is not set
 # CONFIG_DEVFSD_VERBOSE is not set
index 1ce17a5..2c18238 100644 (file)
@@ -1,5 +1,5 @@
 require busybox.inc
-PR = "${INC_PR}.4"
+PR = "${INC_PR}.5"
 
 SRC_URI = "\
   http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
@@ -23,6 +23,7 @@ SRC_URI = "\
   file://defconfig \
   file://mdev \
   file://mdev.conf \
+  file://devfsd.conf \
 "
 
 SRC_URI_append_opendreambox = "\
@@ -45,4 +46,7 @@ do_install_append() {
     install -d ${D}${sysconfdir}/mdev
     install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
     install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
+    if grep "CONFIG_DEVFSD=y" ${WORKDIR}/defconfig; then
+        install -m 644 ${WORKDIR}/devfsd.conf ${D}${sysconfdir}
+    fi
 }
index 687641a..f4cff5b 100644 (file)
@@ -1,8 +1,6 @@
 echo 4 > /proc/progress
 mount -t devfs devfs /dev
-
-mknod /dev/hda1 b 3 1
-mknod /dev/hdc1 b 22 1
+devfsd /dev
 
 echo 12 > /proc/progress
 [ -e /dev/dbox/oled0 ] && ln -s /dev/dbox/oled0 /dev/dbox/lcd0
index 4371c00..4b17841 100755 (executable)
@@ -5,7 +5,7 @@ PRIORITY = "required"
 PROVIDES = "initscripts"
 RPROVIDES_${PN} = "initscripts"
 LICENSE = "GPL"
-PR = "r27"
+PR = "r28"
 
 FILESPATHPKG = "initscripts-${PV}:initscripts:files"
 PACKAGE_ARCH = "${MACHINE_ARCH}"