madwifi-ng: (SlugOS only) re-instate "unset LDFLAGS" in do_compile() in order
authorMike Westerhof <mwester@dls.net>
Mon, 11 May 2009 04:55:22 +0000 (23:55 -0500)
committerMike Westerhof <mwester@dls.net>
Mon, 11 May 2009 04:55:22 +0000 (23:55 -0500)
to make madwifi link successfully after some over-aggressive LDFLAGS changes.

recipes/madwifi/madwifi-ng_r3878-20081204.bb

index 3db8244..f4bd6aa 100644 (file)
@@ -14,7 +14,7 @@ require madwifi-ng_r.inc
 SRCNAME = "madwifi-trunk"
 
 # PR set after the include, to override what's set in the included file.
-PR = "r0"
+PR = "r1"
 
 # It's not clear that we even need the wackelf patches any longer; certainly
 # they are not required for ixp4xx builds.  This needs testing on pxa270.
@@ -23,3 +23,9 @@ WACKELF_SRC_URI_compulab-pxa270 = ""
 
 # This works for EABI as well as the original OABI IXP4xx.
 EXTRA_OEMAKE = "V=1 KERNELPATH=${STAGING_KERNEL_DIR} KERNELRELEASE=${KERNEL_VERSION} TOOLPREFIX=${TARGET_PREFIX}"
+
+# We really must clear out LDFLAGS to get this to link.
+do_compile() {
+       unset LDFLAGS
+       oe_runmake all
+}
\ No newline at end of file