add taglib, a library for reading and editing the meta-data of several popular audio...
authorMichael Lauer <mickey@vanille-media.de>
Sat, 13 Aug 2005 14:33:30 +0000 (14:33 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Sat, 13 Aug 2005 14:33:30 +0000 (14:33 +0000)
don't be surprised, I had to ditch the original buildsystem and use qmake - it may sound
a bit perverted, but that way I could get it to work :)

packages/taglib/.mtn2git_empty [new file with mode: 0644]
packages/taglib/taglib_1.4.bb [new file with mode: 0644]
packages/taglib/taglibc_1.4.bb [new file with mode: 0644]

diff --git a/packages/taglib/.mtn2git_empty b/packages/taglib/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/taglib/taglib_1.4.bb b/packages/taglib/taglib_1.4.bb
new file mode 100644 (file)
index 0000000..2fbd4dc
--- /dev/null
@@ -0,0 +1,38 @@
+DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
+SECTION = "libs"
+HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
+LICENSE = "LGPL"
+
+SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz"
+S = "${WORKDIR}/taglib-${PV}"
+
+inherit autotools qmake-base pkgconfig binconfig
+
+do_configure() {
+       # calling oe_runconf to generate pkgconfig and binconfig files
+       oe_runconf
+       cd ${S}/taglib && rm -f Makefile* && qmake -project -t lib && \
+       qmake -spec ${QMAKESPEC} -after CONFIG=console INCLUDEPATH+=${S}
+}
+
+do_compile() {
+       oe_runmake -C taglib
+}
+
+do_stage_append() {
+       install -d ${STAGING_INCDIR}/taglib
+       for i in `find taglib -name "*.h"`
+       do
+               install $i ${STAGING_INCDIR}/taglib/
+       done
+    for i in `find taglib -name "*.tcc"`
+    do
+        install $i ${STAGING_INCDIR}/taglib/
+    done
+    oe_libinstall -so -C taglib libtaglib ${STAGING_LIBDIR}
+}
+
+do_install() {
+       install -d ${D}${libdir}
+       oe_libinstall -so -C taglib libtaglib ${D}${libdir}
+}
diff --git a/packages/taglib/taglibc_1.4.bb b/packages/taglib/taglibc_1.4.bb
new file mode 100644 (file)
index 0000000..87f85da
--- /dev/null
@@ -0,0 +1,33 @@
+DESCRIPTION = "TagLib is a library for reading and editing the meta-data \
+of several popular audio formats. Currently it supports both ID3v1 and ID3v2 \
+for MP3 files, Ogg Vorbis comments and ID3 tags and Vorbis comments in FLAC files"
+SECTION = "libs"
+HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
+DEPENDS = "taglib"
+LICENSE = "LGPL"
+
+SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz"
+S = "${WORKDIR}/taglib-${PV}"
+
+inherit autotools qmake-base pkgconfig binconfig
+
+do_configure() {
+       echo running oe_runconf to get pkgconfig and binconfig files created          
+       oe_runconf
+       cd ${S}/bindings/c && rm -f Makefile* && qmake -project -o tag_c.pro -t lib && \
+       qmake -spec ${QMAKESPEC} -after CONFIG=console INCLUDEPATH+=${STAGING_INCDIR}/taglib LIBS+=-ltag
+}
+
+do_compile() {
+       oe_runmake -C bindings/c
+}
+
+do_stage_append() {
+       install -d ${STAGING_INCDIR}/taglib
+       install -m 0644 bindings/c/tag_c.h ${STAGING_INCDIR}
+       oe_libinstall -so -C bindings/c libtag_c ${STAGING_LIBDIR}
+}
+
+do_install() {
+    oe_libinstall -so -C bindings/c libtag_c ${D}${libdir}
+}