vlc-gpe: make 0.8.1 work with more recent tremor API. patch courtesy of Philipp Zabel...
authorRene Wagner <rw@handhelds.org>
Wed, 24 Aug 2005 15:56:20 +0000 (15:56 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Wed, 24 Aug 2005 15:56:20 +0000 (15:56 +0000)
packages/vlc/files/.mtn2git_empty [deleted file]
packages/vlc/files/fix-pda.patch [deleted file]
packages/vlc/vlc-gpe-0.8.1/.mtn2git_empty [new file with mode: 0644]
packages/vlc/vlc-gpe-0.8.1/fix-pda.patch [new file with mode: 0644]
packages/vlc/vlc-gpe-0.8.1/vlc-tremor.patch [new file with mode: 0644]
packages/vlc/vlc-gpe_0.8.1.bb

diff --git a/packages/vlc/files/.mtn2git_empty b/packages/vlc/files/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/vlc/files/fix-pda.patch b/packages/vlc/files/fix-pda.patch
deleted file mode 100644 (file)
index 5338851..0000000
+++ /dev/null
@@ -1,104 +0,0 @@
---- vlc-0.8.1/modules/gui/pda/pda.c    2004-11-06 17:35:18.000000000 +0100
-+++ vlc-0.8.1.mod/modules/gui/pda/pda.c        2005-03-11 13:56:52.000000000 +0100
-@@ -417,11 +417,12 @@
-     {
-         input_thread_t *p_input = p_intf->p_sys->p_input;
--        vlc_mutex_lock( &p_input->stream.stream_lock );
-+        vlc_mutex_lock( &p_input->object_lock );
-         if( !p_input->b_die )
-         {
--            /* New input or stream map change */
--            if( p_input->stream.b_changed )
-+           /* New input or stream map change */
-+/*            if( p_input->stream.b_changed )
-+*/
-             {
-                 playlist_t *p_playlist;
-@@ -445,11 +446,14 @@
-             }
-             /* Manage the slider */
--#define p_area p_input->stream.p_selected_area
-+#if 0
-+#define p_area p_input->p_selected_area
-+
-             if (p_intf->p_libvlc->i_cpu & CPU_CAPABILITY_FPU)
-             {
-                 /* Manage the slider for CPU_CAPABILITY_FPU hardware */
--                if( p_input->stream.b_seekable && p_intf->p_sys->b_playing )
-+/*                if( p_input->stream.b_seekable && p_intf->p_sys->b_playing )*/
-+              if (p_intf->p_sys->b_playing)
-                 {
-                     float newvalue = p_intf->p_sys->p_adj->value;
-@@ -471,9 +475,9 @@
-                         double f_pos = (double)newvalue / 100.0;
-                         /* release the lock to be able to seek */
--                        vlc_mutex_unlock( &p_input->stream.stream_lock );
-+                        vlc_mutex_unlock( &p_input->object_lock );
-                         var_SetFloat( p_input, "position", f_pos );
--                        vlc_mutex_lock( &p_input->stream.stream_lock );
-+                        vlc_mutex_lock( &p_input->object_lock );
-                         /* Update the old value */
-                         p_intf->p_sys->f_adj_oldvalue = newvalue;
-@@ -483,7 +487,8 @@
-             else
-             {
-                 /* Manage the slider without CPU_CAPABILITY_FPU hardware */
--                if( p_input->stream.b_seekable && p_intf->p_sys->b_playing )
-+/*                if( p_input->stream.b_seekable && p_intf->p_sys->b_playing )*/
-+              if (p_intf->p_sys->b_playing)
-                 {
-                     off_t newvalue = p_intf->p_sys->p_adj->value;
-@@ -505,9 +510,9 @@
-                         double f_pos = (double)newvalue / 100.0;
-                         /* release the lock to be able to seek */
--                        vlc_mutex_unlock( &p_input->stream.stream_lock );
-+                        vlc_mutex_unlock( &p_input->object_lock );
-                         var_SetFloat( p_input, "position", f_pos );
--                        vlc_mutex_lock( &p_input->stream.stream_lock );
-+                        vlc_mutex_lock( &p_input->object_lock );
-                         /* Update the old value */
-                         p_intf->p_sys->i_adj_oldvalue = newvalue;
-@@ -515,8 +520,9 @@
-                 }
-             }
- #undef p_area
-+#endif
-         }
--        vlc_mutex_unlock( &p_input->stream.stream_lock );
-+        vlc_mutex_unlock( &p_input->object_lock );
-     }
-     else if( p_intf->p_sys->b_playing && !p_intf->b_die )
-     {
-@@ -594,20 +600,14 @@
-     if( p_intf->p_sys->p_input )
-     {
-         /* initialize and show slider for seekable streams */
--        if( p_intf->p_sys->p_input->stream.b_seekable )
-+/*        if( p_intf->p_sys->p_input->stream.b_seekable )*/
-         {
-             gtk_widget_show( GTK_WIDGET( p_slider ) );
-         }
--        else
--        {
--            /* hide slider */
--            gtk_widget_hide( GTK_WIDGET( p_slider ) );
--        }
--
-         /* control buttons for free pace streams */
--        b_control = p_intf->p_sys->p_input->stream.b_pace_control;
-+        b_control = p_intf->p_sys->p_input->b_can_pace_control;
--        p_intf->p_sys->p_input->stream.b_changed = 0;
-+/*        p_intf->p_sys->p_input->stream.b_changed = 0;*/
-         msg_Dbg( p_intf, "stream has changed, refreshing interface" );
-     }
diff --git a/packages/vlc/vlc-gpe-0.8.1/.mtn2git_empty b/packages/vlc/vlc-gpe-0.8.1/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/vlc/vlc-gpe-0.8.1/fix-pda.patch b/packages/vlc/vlc-gpe-0.8.1/fix-pda.patch
new file mode 100644 (file)
index 0000000..5338851
--- /dev/null
@@ -0,0 +1,104 @@
+--- vlc-0.8.1/modules/gui/pda/pda.c    2004-11-06 17:35:18.000000000 +0100
++++ vlc-0.8.1.mod/modules/gui/pda/pda.c        2005-03-11 13:56:52.000000000 +0100
+@@ -417,11 +417,12 @@
+     {
+         input_thread_t *p_input = p_intf->p_sys->p_input;
+-        vlc_mutex_lock( &p_input->stream.stream_lock );
++        vlc_mutex_lock( &p_input->object_lock );
+         if( !p_input->b_die )
+         {
+-            /* New input or stream map change */
+-            if( p_input->stream.b_changed )
++           /* New input or stream map change */
++/*            if( p_input->stream.b_changed )
++*/
+             {
+                 playlist_t *p_playlist;
+@@ -445,11 +446,14 @@
+             }
+             /* Manage the slider */
+-#define p_area p_input->stream.p_selected_area
++#if 0
++#define p_area p_input->p_selected_area
++
+             if (p_intf->p_libvlc->i_cpu & CPU_CAPABILITY_FPU)
+             {
+                 /* Manage the slider for CPU_CAPABILITY_FPU hardware */
+-                if( p_input->stream.b_seekable && p_intf->p_sys->b_playing )
++/*                if( p_input->stream.b_seekable && p_intf->p_sys->b_playing )*/
++              if (p_intf->p_sys->b_playing)
+                 {
+                     float newvalue = p_intf->p_sys->p_adj->value;
+@@ -471,9 +475,9 @@
+                         double f_pos = (double)newvalue / 100.0;
+                         /* release the lock to be able to seek */
+-                        vlc_mutex_unlock( &p_input->stream.stream_lock );
++                        vlc_mutex_unlock( &p_input->object_lock );
+                         var_SetFloat( p_input, "position", f_pos );
+-                        vlc_mutex_lock( &p_input->stream.stream_lock );
++                        vlc_mutex_lock( &p_input->object_lock );
+                         /* Update the old value */
+                         p_intf->p_sys->f_adj_oldvalue = newvalue;
+@@ -483,7 +487,8 @@
+             else
+             {
+                 /* Manage the slider without CPU_CAPABILITY_FPU hardware */
+-                if( p_input->stream.b_seekable && p_intf->p_sys->b_playing )
++/*                if( p_input->stream.b_seekable && p_intf->p_sys->b_playing )*/
++              if (p_intf->p_sys->b_playing)
+                 {
+                     off_t newvalue = p_intf->p_sys->p_adj->value;
+@@ -505,9 +510,9 @@
+                         double f_pos = (double)newvalue / 100.0;
+                         /* release the lock to be able to seek */
+-                        vlc_mutex_unlock( &p_input->stream.stream_lock );
++                        vlc_mutex_unlock( &p_input->object_lock );
+                         var_SetFloat( p_input, "position", f_pos );
+-                        vlc_mutex_lock( &p_input->stream.stream_lock );
++                        vlc_mutex_lock( &p_input->object_lock );
+                         /* Update the old value */
+                         p_intf->p_sys->i_adj_oldvalue = newvalue;
+@@ -515,8 +520,9 @@
+                 }
+             }
+ #undef p_area
++#endif
+         }
+-        vlc_mutex_unlock( &p_input->stream.stream_lock );
++        vlc_mutex_unlock( &p_input->object_lock );
+     }
+     else if( p_intf->p_sys->b_playing && !p_intf->b_die )
+     {
+@@ -594,20 +600,14 @@
+     if( p_intf->p_sys->p_input )
+     {
+         /* initialize and show slider for seekable streams */
+-        if( p_intf->p_sys->p_input->stream.b_seekable )
++/*        if( p_intf->p_sys->p_input->stream.b_seekable )*/
+         {
+             gtk_widget_show( GTK_WIDGET( p_slider ) );
+         }
+-        else
+-        {
+-            /* hide slider */
+-            gtk_widget_hide( GTK_WIDGET( p_slider ) );
+-        }
+-
+         /* control buttons for free pace streams */
+-        b_control = p_intf->p_sys->p_input->stream.b_pace_control;
++        b_control = p_intf->p_sys->p_input->b_can_pace_control;
+-        p_intf->p_sys->p_input->stream.b_changed = 0;
++/*        p_intf->p_sys->p_input->stream.b_changed = 0;*/
+         msg_Dbg( p_intf, "stream has changed, refreshing interface" );
+     }
diff --git a/packages/vlc/vlc-gpe-0.8.1/vlc-tremor.patch b/packages/vlc/vlc-gpe-0.8.1/vlc-tremor.patch
new file mode 100644 (file)
index 0000000..2a5a924
--- /dev/null
@@ -0,0 +1,14 @@
+--- vlc-0.8.1/modules/codec/vorbis.c.orig      2005-08-05 19:57:05 +0200
++++ vlc-0.8.1/modules/codec/vorbis.c   2005-08-05 20:01:22 +0200
+@@ -481,7 +481,11 @@
+ #endif
+     if( p_oggpacket->bytes &&
++#ifdef MODULE_NAME_IS_tremor
++        vorbis_synthesis( &p_sys->vb, p_oggpacket, 1 ) == 0 )
++#else
+         vorbis_synthesis( &p_sys->vb, p_oggpacket ) == 0 )
++#endif
+         vorbis_synthesis_blockin( &p_sys->vd, &p_sys->vb );
+     /* **pp_pcm is a multichannel float vector. In stereo, for
index f433803..599701d 100644 (file)
@@ -4,12 +4,13 @@ LICENSE = "GPL"
 PRIORITY = "optional"
 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
 SECTION = "gpe"
-PR = "r3"
+PR = "r4"
 
 DEPENDS = "gtk+ freetype gnutls tremor faad2 ffmpeg flac liba52 libid3tag libmad mpeg2dec"
 
 SRC_URI = "http://download.videolan.org/pub/videolan/vlc/${PV}/vlc-${PV}.tar.gz \
-file://fix-pda.patch;patch=1"
+       file://fix-pda.patch;patch=1 \
+       file://vlc-tremor.patch;patch=1"
 S = "${WORKDIR}/vlc-${PV}"
 
 inherit autotools