ortp-0.13.1 : Add later version of ortp. Convert to use .inc.
authorPhilip Balister <philip@balister.org>
Sat, 9 May 2009 15:34:04 +0000 (11:34 -0400)
committerPhilip Balister <philip@balister.org>
Sat, 9 May 2009 15:34:04 +0000 (11:34 -0400)
              * There are later versions, but this version is needed
                for openbts.

conf/checksums.ini
recipes/ortp/ortp.inc [new file with mode: 0644]
recipes/ortp/ortp_0.13.1.bb [new file with mode: 0644]
recipes/ortp/ortp_0.7.1.bb

index 9903008..eb1affe 100644 (file)
@@ -1,3 +1,7 @@
+[http://download.savannah.nongnu.org/releases/linphone/ortp/sources/ortp-0.13.1.tar.gz]
+md5=293f16da6dd434e68652f0f725b7f97c
+sha256=2ba471a2a4f1d7f10fb70de5b68dbb7d32b43494efcecb88b3bd8445f630494c
+
 [http://www.directfb.org/downloads/Extras/++DFB-0.9.25.tar.gz]
 md5=c6a2705f6210d8ede50a947b375f1c0b
 sha256=b3dbf01563dd60d63cff543ea8cd0c885381e78ecbbab8ff176e46df3f198a88
diff --git a/recipes/ortp/ortp.inc b/recipes/ortp/ortp.inc
new file mode 100644 (file)
index 0000000..c05e9d5
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "An LGPL implementation of RTP - RFC3550"
+LICENSE = "LGPL"
+DEPENDS = "glibc "
+
+PR = "r1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/linphone/${PN}/sources/${P}.tar.gz"
+
+do_compile_append() {
+        sed -i -e s:${STAGING_DIR_TARGET}::g \
+               -e s:/${TARGET_SYS}::g \
+                  ortp.pc
+
+}
+
+do_stage () {
+       autotools_stage_all
+}
diff --git a/recipes/ortp/ortp_0.13.1.bb b/recipes/ortp/ortp_0.13.1.bb
new file mode 100644 (file)
index 0000000..ae06320
--- /dev/null
@@ -0,0 +1,2 @@
+require ortp.inc
+
index c05e9d5..0318301 100644 (file)
@@ -1,20 +1,4 @@
-DESCRIPTION = "An LGPL implementation of RTP - RFC3550"
-LICENSE = "LGPL"
-DEPENDS = "glibc "
+require ortp.inc
 
 PR = "r1"
 
-inherit autotools pkgconfig
-
-SRC_URI = "http://download.savannah.nongnu.org/releases/linphone/${PN}/sources/${P}.tar.gz"
-
-do_compile_append() {
-        sed -i -e s:${STAGING_DIR_TARGET}::g \
-               -e s:/${TARGET_SYS}::g \
-                  ortp.pc
-
-}
-
-do_stage () {
-       autotools_stage_all
-}