linux-omap 2.6.29: fix FIFO issues with large transfers on the MUSB controller
authorRobert Nelson <robert.nelson@digikey.com>
Thu, 5 Nov 2009 11:49:22 +0000 (12:49 +0100)
committerKoen Kooi <koen@openembedded.org>
Thu, 5 Nov 2009 11:49:22 +0000 (12:49 +0100)
recipes/linux/linux-omap-2.6.29/musb/0030-musb-fifo.patch [new file with mode: 0644]
recipes/linux/linux-omap_2.6.29.bb

diff --git a/recipes/linux/linux-omap-2.6.29/musb/0030-musb-fifo.patch b/recipes/linux/linux-omap-2.6.29/musb/0030-musb-fifo.patch
new file mode 100644 (file)
index 0000000..8ac3707
--- /dev/null
@@ -0,0 +1,26 @@
+diff --git a/drivers/usb/musb/musb_core.c b/drivers/usb/musb/musb_core.c
+index d3b8e0e..cee974e 100644
+--- a/drivers/usb/musb/musb_core.c
++++ b/drivers/usb/musb/musb_core.c
+@@ -1103,15 +1103,12 @@ static struct fifo_cfg __initdata mode_4_cfg[] = {
+ { .hw_ep_num =  8, .style = FIFO_RX,   .maxpacket = 512, },
+ { .hw_ep_num =  9, .style = FIFO_TX,   .maxpacket = 512, },
+ { .hw_ep_num =  9, .style = FIFO_RX,   .maxpacket = 512, },
+-{ .hw_ep_num = 10, .style = FIFO_TX,   .maxpacket = 256, },
+-{ .hw_ep_num = 10, .style = FIFO_RX,   .maxpacket = 64, },
+-{ .hw_ep_num = 11, .style = FIFO_TX,   .maxpacket = 256, },
+-{ .hw_ep_num = 11, .style = FIFO_RX,   .maxpacket = 64, },
+-{ .hw_ep_num = 12, .style = FIFO_TX,   .maxpacket = 256, },
+-{ .hw_ep_num = 12, .style = FIFO_RX,   .maxpacket = 64, },
+-{ .hw_ep_num = 13, .style = FIFO_RXTX, .maxpacket = 4096, },
+-{ .hw_ep_num = 14, .style = FIFO_RXTX, .maxpacket = 1024, },
+-{ .hw_ep_num = 15, .style = FIFO_RXTX, .maxpacket = 1024, },
++{ .hw_ep_num = 10, .style = FIFO_TX,   .maxpacket = 512, },
++{ .hw_ep_num = 10, .style = FIFO_RX,   .maxpacket = 512, },
++{ .hw_ep_num = 11, .style = FIFO_RXTX, .maxpacket = 512, },
++{ .hw_ep_num = 12, .style = FIFO_RXTX, .maxpacket = 4096,},
++{ .hw_ep_num = 13, .style = FIFO_RXTX, .maxpacket = 512, },
++{ .hw_ep_num = 14, .style = FIFO_RXTX, .maxpacket = 512, },
+ };
index 130f9a8..6996416 100644 (file)
@@ -131,6 +131,7 @@ SRC_URI_append = " \
            file://musb/0027-musb-otg-timer-cleanup.patch;patch=1 \
            file://musb/0028-musb-make-initial-HNP-roleswitch-work-v2.patch;patch=1 \
            file://musb/0029-musb-support-disconnect-after-HNP-roleswitch.patch;patch=1 \
+           file://musb/0030-musb-fifo.patch;patch=1 \
            file://isp/v4l/0001-V4L2-Add-COLORFX-user-control.patch;patch=1 \
            file://isp/v4l/0002-V4L-Int-if-v4l2_int_device_try_attach_all-requires.patch;patch=1 \
            file://isp/v4l/0003-V4L-Int-if-Dummy-slave.patch;patch=1 \