e-wm: add patch to not install the illume default keyboards
authorKlaus Kurzmann <mok@fluxnetz.de>
Sat, 5 Dec 2009 19:27:48 +0000 (20:27 +0100)
committerKlaus Kurzmann <mok@fluxnetz.de>
Sat, 5 Dec 2009 19:27:48 +0000 (20:27 +0100)
and RRECOMMEND the new illume-keyboard-default-* ones.
This way they can be easily replaced by others...

Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
recipes/e17/e-wm/drop-illume-keyboards.patch [new file with mode: 0644]
recipes/e17/e-wm_svn.bb

diff --git a/recipes/e17/e-wm/drop-illume-keyboards.patch b/recipes/e17/e-wm/drop-illume-keyboards.patch
new file mode 100644 (file)
index 0000000..0abe6f2
--- /dev/null
@@ -0,0 +1,17 @@
+Index: e/src/modules/illume/keyboards/Makefile.am
+===================================================================
+--- e/src/modules/illume/keyboards/Makefile.am (revision 43437)
++++ e/src/modules/illume/keyboards/Makefile.am (working copy)
+@@ -4,12 +4,6 @@
+ filesdir = $(libdir)/enlightenment/modules/$(MODULE)/keyboards
+ files_DATA = \
+             ignore_built_in_keyboards \
+-            Default.kbd \
+-            alpha.png \
+-          Numbers.kbd \
+-            numeric.png \
+-            Terminal.kbd \
+-          qwerty.png \
+           up.png \
+           down.png \
+           left.png \
index fe65620..b4e35b6 100644 (file)
@@ -3,7 +3,7 @@ DEPENDS = "eet evas ecore edje efreet edbus"
 LICENSE = "MIT BSD"
 SRCNAME = "e"
 PV = "0.16.999.060+svnr${SRCPV}"
-PR = "r8"
+PR = "r9"
 
 inherit e update-alternatives
 
@@ -12,6 +12,7 @@ SRC_URI += "\
   file://applications.menu \
   file://gsm-segfault-fix.patch;patch=1;maxrev=37617 \
   file://fix-profiles.diff;patch=1;maxrev=39889 \
+  file://drop-illume-keyboards.patch;patch=1 \
 "
 
 SRC_URI_append_openmoko = " file://illume-disable-screensaver.patch;patch=1"
@@ -145,7 +146,13 @@ FILES_${PN}-utils = "${libdir}/enlightenment/utils/*"
 FILES_${PN}-menu = "${sysconfdir}/xdg/menus/applications.menu"
 
 RRECOMMENDS_${PN}-config-default = "${PN}-theme-default"
-RRECOMMENDS_${PN}-config-illume = "${PN}-theme-illume"
+RRECOMMENDS_${PN}-config-illume = "\
+  ${PN}-theme-illume \
+  illume-keyboard-default-alpha \
+  illume-keyboard-default-numeric \
+  illume-keyboard-default-terminal \
+"
+
 RRECOMMENDS_${PN}-config-minimalist = "\
   ${PN}-background-light-gradient \
   ${PN}-theme-default \